PAT甲级A1051答案(使用C语言)

题目描述

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目要求总结:

给定一个栈的容量,按1-n的顺序输入,再给定K个输出顺序,判断这些输出顺序是否合理,若合理,输出“YES”,否则输出“NO”;

解题思路

这里涉及栈输出顺序是否合理的判断,解决方法如下:
1.设置两个数组,一个存放入栈的顺序,一个存放要判断的输出顺序
2.设置指针pos,初始时指向输出顺序的第一个数;由于栈的容量有限制,所以要设置一个是否溢栈的标志flag = 0;
3.创建一个栈,每次判断一个顺序前先将栈清空,然后按顺序入栈,每入栈一个元素,首先判断是否溢出,若溢出,则将flag设置为1,否则比较栈顶元素和输出顺序的指针pos所指向的元素是否相同,如果相同,则将栈顶元素出栈,并将pos移动到下一位,如果不同,则继续入栈

AC代码

#include<stdio.h>
#include<stdlib.h>
#include<stack>
using namespace std;

int main(){
	stack<int> s;
	int m, n, k, num[10000]; //num用于存放输出的顺序
	scanf("%d%d%d", &m, &n, &k);
	
	for(int i = 0; i < k; i++){
		
		for(int j = 0; j < n; j++) scanf("%d", &num[j]); //依次输入存放的元素
		int pos = 0, flag = 0; //pos和flag分别用来指向输出顺序中的数和判断栈是否溢出
		while(s.size()) s.pop(); //清空栈
		
		for(int l = 1; l <= n; l++){
			s.push(l); //入栈
			//判断栈的大小是否大于给定的值
			if(s.size() > m){
				flag = 1; //若大于,说明溢出,将flag设置为1,跳到下一次循环
				break;
			}
			//比较栈顶元素和pos指向的元素是否相等,若相等的话直接出栈到指向的值不相等为止
			while(s.size() && num[pos] == s.top()){
				pos++;  //相等的话pos移动至下一位
				s.pop();//出栈栈顶元素
			}
		}
		//判断栈的元素是否全部出栈,并且看flag是否没有改变
		if(s.size() == 0 && flag == 0){
			printf("YES\n");
		}
		else{
			printf("NO\n");
		}


	}
	return 0;
}```

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值