HDU 3635 Dragon Balls(带权并查集)

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3297    Accepted Submission(s): 1269


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 
题目大意:给N颗星球,M种操作,每颗星球都有一颗龙珠,T代表将A所在星球所有龙珠转移到B所在星球,Q代表询问,输入x,输出x号龙珠在哪,x所在星球共有多少克龙珠,x号龙珠共被转移了几次,啊,好麻烦的题目,明明就7颗龙珠嘛...我读书少不要骗我,不扯淡了 ,看代码

题目链接:点击打开链接

代码注释:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100005
int father[N],num[N],move[N];//num记载每颗星球龙珠总数,move记载每颗龙珠移动次数
int n;
void init()
{
    for(int i=1; i<=n; i++)
    {
        father[i]=-1;
        num[i]=1;
        move[i]=0;
    }
}
int find(int x)
{
    if(father[x]==-1)
        return x;
    int t=father[x];
    father[x]=find(father[x]);
    move[x]+=move[t];
    return father[x];
}
void make(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        father[x]=y;
        num[y]+=num[x];
        move[x]++;
    }
}
int main()
{
    int T,m,t=1;
    char ord[10];
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        init();
        printf("Case %d:\n",t++);
        while(m--)
        {
            cin>>ord;
            if(ord[0]=='T')
            {
                int x,y;
                scanf("%d%d",&x,&y);
                make(x,y);
            }
            else
            {
                int x,y;
                scanf("%d",&x);
                y=find(x);
                printf("%d %d %d\n",y,num[y],move[x]);
            }
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值