HDU3635 Dragon Balls———并查集

Dragon Balls
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8090 Accepted Submission(s): 2995

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
这里写图片描述
His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0<T<=100). T ( 0 < T <= 100 ) .
For each case, the first line contains two integers: NandQ(2<N<=10000,2<Q<=10000). N a n d Q ( 2 < N <= 10000 , 2 < Q <= 10000 ) .
Each of the following Q lines contains either a fact or a question as the follow format:
T A B T   A   B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
QA Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1<=A,B<=N) ( 1 <= A , B <= N )

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers  X Y Z    X   Y   Z   saparated by a blank space.

Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2


题意:
n个城市有n颗龙珠,开始时第i颗龙珠在第i个城市,经过一段时间,一些城市的龙珠会转移到其他城市
- T A B表示A所在的城市的龙珠都转移到B城市
每次询问 Q A:
输出

  • A龙珠在哪个城市
  • A 所在的城市有多少颗龙珠
  • A龙珠转移的次数。

#include<bits/stdc++.h>
using namespace std;
const int MAXN=10005;
int par[MAXN];//i 的父亲是 par[i]  (parent)
int ran[MAXN];//记录移动次数
int ad[MAXN];//记录数量
int n,m;

void init()
{
    memset(ran,0,sizeof(ran));//初始时移动次数全是0
    for(int i=1;i<=n;i++)
    {
        par[i]=i;//自己的上级是自己
        ad[i]=1;//每个城市只有一个龙珠
    }
}
int find(int x)//找 x 的根节点
{
    if(x==par[x])   return x;//自己就是根节点的情况下直接输出
    int t=find(par[x]);//x 的根节点是 t
    ran[x] += ran[par[x]];// x 的移动次数等于自己的移动次数加上自己跟着父亲的移动次数
    par[x]=t;//路径压缩
    return  t;
}
void join(int x,int y)
{
    if(x==y)    return ;
    par[x]=y;//y是上级
    ran[x]=1;//根节点的移动次数是1
    ad[y] += ad[x];//
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int z=1;z<=t;z++)
    {
        scanf("%d %d",&n,&m);
        getchar();
        init();
//        printf("%d %d\n",n,m);
        printf("Case %d:\n",z);
        for(int i=0;i<m;i++)
        {
            char ch;
            int a,b,q;
            scanf("%c",&ch);
            if(ch=='T')
            {
                scanf("%d %d",&a,&b);
                int fa=find(a);
                int fb=find(b);
                join(fa,fb);
                getchar();
            }
            if(ch=='Q')
            {
                scanf("%d",&q);
                int fq=find(q);
                printf("%d %d %d\n",fq,ad[fq],ran[q]);
                getchar();
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值