1020 Tree Traversals (25 分)——甲级:已知后序、中序,输出层序(二叉树、对于建树递归算法的理解)

16 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

题目大意:给定二叉树的后序、中序,输出层序。
思路:根据后序、中序建树,然后BFS输出层序。

代码如下:

#include <iostream>
#include <queue>
using namespace std;
typedef struct node* tree;
struct node
{
    int data;
    tree left;
    tree right;
};
int post[50], in[50];
tree build(int postl, int postr, int inl, int inr)
{
    if(postl > postr) return NULL;
    int i = inl;
    while(i<inr && in[i]!=post[postr]) i++;
    int sum = i-inl;
    tree t = new node;
    t->data = post[postr];
    t->left = build(postl, postl+sum-1, inl, i-1);
    t->right = build(postl+sum, postr-1, i+1, inr);
    return t;
}
void bfs(tree root, int n)
{
    queue<tree>q;
    int cnt = 0;
    q.push(root);
    while(!q.empty())
    {
        tree x = q.front();
        cnt++;
        if(cnt == n) cout << x->data << endl;
        else cout << x->data << " ";
        if(x->left != NULL) q.push(x->left);
        if(x->right != NULL) q.push(x->right);
        q.pop();
    }
}
int main()
{
    int n;
    cin >> n;
    int i;
    for(i = 1; i <= n; i++) cin >> post[i];
    for(i = 1; i <= n; i++) cin >> in[i];
    tree root = build(1, n, 1, n);
    bfs(root, n);
    return 0;
}


一直对建树的递归算法都不算认识得很清楚。。。通过这题希望让自己认识得更清晰。理解如下:

tree build(int postl,int postr,int inl,int inr)
{
    if(postl>postr) return NULL;/*如果树已经空了,则返回空指针。
    							  比如t->left递归到这里,树已空,那么就意味着没有左儿子*/
    int i=inl;//从中序起始位置开始找根节点索引
    while(i<inr&&in[i]!=post[postr]) i++;
    int sum=i-inl;//左子树大小
    tree t=new node;
    t->data=post[postr];

	//如下图
    t->left=build(postl,postl+sum-1,inl,i-1);
    t->right=build(postl+sum,postr-1,i+1,inr);
    return t;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值