Wireless Network(并查集)

题目

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

题目大意

有很多台电脑,两台电脑距离在D之内才能通信,或者通过第三台电脑进行通信。判断两台电脑能否通信。

思路

先判断两台电脑的距离是否符合题意再判断两台电脑是否修好了,都满足的话让这两台电脑为一个祖宗,如果这两台电脑的祖宗的祖宗相同即可以通信.

#include<stdio.h>
#include<string.h>
#include<math.h>
int n,k;
int a[1010][1010];
int book[1010];
int aa[1010];
void f()
{
	int i;
	for(i=1;i<=n;i++)
	aa[i]=i;
}
int geta(int x)
{
	if(aa[x]==x)
	return x;
	else
	aa[x]=geta(aa[x]);
	return aa[x];
}
void ff(int x,int y)
{
	int t1,t2;
	t1=geta(x);
	t2=geta(y);
	if(t1!=t2)
		aa[t2]=t1;
}
void fff()
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		if(book[i]&&a[i][k])
		ff(i,k);
	}
}
struct node
{
	int x,y;
}t[1010];
int main()
{
	int i,j,xx,yy;
	double s,d;
	char x;
	memset(book,0,sizeof(book));
	scanf("%d %lf",&n,&d);
	for(i=1;i<=n;i++)
	scanf("%d %d",&t[i].x,&t[i].y);
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			s=(t[i].x-t[j].x)*(t[i].x-t[j].x)*1.0+(t[i].y-t[j].y)*(t[i].y-t[j].y)*1.0;
			if(s<=d*d)
			a[i][j]=1;
			
		}
	}
	f();
	while(~scanf("%c",&x))
	{
		if(x=='O')
		{
			scanf("%d",&k);
			book[k]=1;	
			fff();//每次修好一台就让它找到祖宗
		}
		else if(x=='S')
		{
			scanf("%d %d",&xx,&yy);
			if(geta(aa[xx])==geta(aa[yy]))
			printf("SUCCESS\n");	
			else
			printf("FAIL\n");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺碎冰冰冰冰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值