Wireless Network 带权并查集

Wireless Network
Time Limit: 10000MS
Memory Limit: 65536K
Total Submissions: 29523
Accepted: 12255

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source


题意 输入n 和 d  ;下面是n个坐标,就是已经没网络的,标号即为顺序;
下是操作 O  k 就是修复第K的坐标的网络;
S   j    k  就是判断 j到k是否能通过网络连接上,没俩个网络之间的距离不超过d;

也是个带权的并查集  修复的时候判断一下与其他网络是否能连接上,能的话就和为一个集合;
最后判断j和k是否同属于一个集合即可;


#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int M=1010;
struct node
{
     int x ;
     int y;
} ;
node point[M] ;
int par[M];
bool flag[M];
int n,d ;
void init()
{
      for(int i=1 ;i<=n ;i++)
              par[i]=i ;
}
int  find(int x)
{
      return  (par[x]==x) ?  x : par[x]=find(par[x]) ;
}
void unite(int a,int b)
{
        int distance=(point[a].x-point[b].x)*(point[a].x-point[b].x)+(point[a].y-point[b].y)*(point[a].y -point[b].y) ;
        a=find(a) ;
        b=find(b) ;
        if(distance<=d*d&&a!=b)
        {
                 par[a]=b ;
        }
}
int main()
{
    int i ;
    cin>>n>>d ;
    for(i=1 ;i<=n ;i++)
          cin>>point[i].x>>point[i].y;
     char ch;
     int temp;
     init();
     memset(flag,false ,sizeof(flag));
     while(cin>>ch)
     {


               if(ch=='O')
               {
                   cin>>temp;
                   flag[temp]=true;
                   for(i=1;i<=n;i++)
                         if(flag[i]==true&&i!=temp)
                                 unite(i,temp) ;
               }
               else
               {
                       int p,q ;
                       cin>>p>>q ;
                       if(find(p)==find(q))
                               cout<<"SUCCESS"<<endl  ;
                       else
                               cout<<"FAIL"<<endl ;
               }
     }
    return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值