Play on Words HDU - 1116

题目

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word acm'' can be followed by the wordmotorola’’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
欧拉通路:
满足3个条件
1.图连通;
2.除2个端点外其余节点入度=出度;
3.1个端点入度比出度大1;一个端点入度比出度小1 或 所有节点入度等于出度

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int in[50];
int out[50];
int a[50];
int book[50];
void f()
{
	int i;
	for(i=0;i<26;i++)
	a[i]=i;
}
int geta(int x)
{
	if(x==a[x])
	return x;
	else
	{
		a[x]=geta(a[x]);
		return a[x];
	}
}
void merge(int m,int n)
{
	int t2,t1;
	t1=geta(m);
	t2=geta(n);
	if(t1!=t2)
	a[t2]=t1;
 } 
int main()
{
	char s[1005];
	int t,n,i,j,x,y,count,k;
	scanf("%d",&t);
	while(t--)	
	{
		f();
		memset(book,0,sizeof(book));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%s",s);
			x=s[0]-'a';
			y=s[strlen(s)-1]-'a';
			merge(x,y);
			in[y]++;
			out[x]++;
			book[x]=book[y]=1;
		}
		count=0;
		for(i=0;i<26;i++)
		{
			if(book[i]&&a[i]==i)
			count++;
		}
		if(count>1)
		{
			printf("The door cannot be opened.\n");
			continue;
		}
		k=0;
		int h[50];
		for(i=0;i<26;i++)
		{
			if(book[i]&&in[i]!=out[i])
			h[k++]=i;
		}
		if(k==0)
		{
			printf("Ordering is possible.\n");
			continue;
		}
		if(k==2&&((out[h[0]]-in[h[0]]==1&&in[h[1]]-out[h[1]]==1)||(out[h[1]]-in[h[1]]==1 && in[h[0]]-out[h[0]]==1)))
		{
			printf("Ordering is possible.\n");
			continue;
		}
		printf("The door cannot be opened.\n");
	}
	return 0;
}
//欧拉通路: 通过图中每条边且只通过一次,并且经过每一顶点的通路。 欧拉通路:图连通;除2个端点外其余节点入度=出度;1个端点入度比出度大1;一个端点入度比出度小1 或 所有节点入度等于出度 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺碎冰冰冰冰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值