Play on Words

hdu-1116传送门

题目

Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word acm'' can be followed by the wordmotorola’’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.

Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
题解:
将每个单词的第一个字母看作起点,最后一个字母看作终点,再判断是否是欧拉回路,
注:欧拉路分为欧拉回路和欧拉通路;
欧拉通路:满足从一点出发经过每一条边且只经过一次,能把所有的边都经过的路
欧拉回路:欧拉通路并且最后回到原点的路;
欧拉路:图连通,存在一个顶点的入度比出度大1,一个顶点的出度比入度大1,其他顶点入度与出度相等
一、无向图
每个顶点的度数都是偶数,则存在欧拉回路。
二、有向图(所有边都是单向的)
每个节顶点的入度都等于出度,则存在欧拉回路。

#include<stdio.h>
#include<string.h> 
int in[30],out[30],book[30];
int a[50];
void init()
{
	int i;
	for(i=0;i<26;i++)
	a[i]=i;
}
int geta(int x)
{
	if(x==a[x])
	return a[x];
	else
	{
		a[x]=geta(a[x]);
		return a[x];
	}
}
void merge(int m,int n)
{
	int t1,t2;
	t1=geta(m);
	t2=geta(n);
	if(t1!=t2)
	a[t2]=t1;
}
int main()
{
	int t,n,i,x,k[30];;
	char s[1010],q,p;
	scanf("%d",&t);
	while(t--)
	{
		init();
		memset(book,0,sizeof(book));
		memset(k,0,sizeof(k));
		memset(in,0,sizeof(in));
		memset(out,0,sizeof(out));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%s",s);
			p=s[0]-'a';
			q=s[strlen(s)-1]-'a';
			merge(p,q);
			book[p]=1;
			book[q]=1;
			in[q]++;
			out[p]++;
		}
		int cnt=0;
		for(i=0;i<26;i++)
			{
				if(book[i]&&a[i]==i)
				cnt++;
			}
			if(cnt!=1)
			{
				printf("The door cannot be opened.\n");
				continue;
			}
			cnt=0;
		for(i=0;i<26;i++)
		{
			if(book[i]&&out[i]!=in[i])
			{
				k[cnt]=i;
				cnt++;
			}
		}
		if(cnt==0)
		{
			printf("Ordering is possible.\n");
			continue;
		}
		else if(cnt==2)
		{
			if((out[k[0]]-in[k[0]]==1&&in[k[1]]-out[k[1]]==1)||(out[k[1]]-in[k[1]]==1 && in[k[0]]-out[k[0]]==1))
			{
				printf("Ordering is possible.\n");
				continue;
			}
		}
		//else
		printf("The door cannot be opened.\n");
	}
	return 0; 
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺碎冰冰冰冰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值