poj Play on Words(1386)

Play on Words
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9496 Accepted: 3284

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.
题目大意:

读入一组单词,判定是否可以经过重组使得每一个单词第一个字母跟前一个单词的最后一个字母相同,如 acm  motorola 是可以打开门的。

数据范围:

单词个数 1<=N<=100000,每个单词长度 2到1000个小写字母。

题目分折:

首尾字母连成一条有向边,构成一个有向图,便转化为是否存在一条路径经过每一条边一次且一次,(并不要求回到第一个字母的开头),这很显是  欧拉通路 问题。

1,统计入度与出度,与此同时使用并查集合并属于同一连通图的边(用以判定基图是否连通)。

2,判定入度与出席,并宏富基图是否连通。

小乐一下:

有向图D存在欧拉通路的充要条件是:D为有向图,而且D的基图(去掉有向)连通,并且所有顶点的出席与入度之差相等,或者仅有两个顶点的出度与入度之差为1.

题目链接:http://poj.org/problem?id=1386

代码:

#include<cstdio>
#include<cstring>
#define maxn 100010
#define INF 0x3ffffff
int T,N;
char word[1010];
int od[26],id[26];
int based[26];int father[26];

int Find(int x){
    if(x!=father[x]) return father[x] = Find(father[x]);
    return x;
}
void Bing(int x,int y){
    int fx = Find(x);
    int fy = Find(y);
    if(fx != fy) father[fx] = fy;
}


int main(){
    int u,v;
    int i,j;
    scanf("%d",&T);
    while(T--){
        memset(od,0,sizeof(od));
        memset(id,0,sizeof(id));
        memset(based,0,sizeof(based));
        for(i = 0;i<26;i++) father[i] = i;
        scanf("%d",&N);
        for(i = 0;i<N;i++){
            scanf("%s",word);
            u = word[0] - 'a';v = word[strlen(word)-1]-'a';
            od[u]++;id[v]++;
            based[u] = based[v] = 1; //在统计入度与出度的同时使用并查集。
            Bing(u,v);
        }
        for(i = 0;i<26;i++) if(based[i]) break;
        int x = Find(i);
        for(i = i+1;i<26;i++){
            if(based[i] && x!=Find(i)) break;  //判定基图是否连通。
        }
        if(i<26){
            printf("The door cannot be opened.\n");
            continue;
        }
        int count1 = 0;
        int count2 = 0;
        for(i = 0;i<26;i++){
            if(based[i]){
                if(id[i]!=od[i]) count1++;
                if(id[i]-od[i]==1 || od[i]-id[i]==1) count2++;
            }
        }
        if(count1==0 || (count1==2 && count2==2)) printf("Ordering is possible.\n");  //根据有向图的欧拉通路充要条件进行判定,是否存在有向欧拉通路。
        else printf("The door cannot be opened.\n");
    }
}
伟大的梦想成就伟大的人,从细节做好,从点点滴滴做好,从认真做好。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值