POJ2965——DFS+枚举——The Pilots Brothers' refrigerator

借用朋友的代码,感觉很正规,链接http://home.cnblogs.com/u/get-an-AC-everyday/

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion
大意:改变一个,横和数都改变,关键是超时,在回溯的时候,用一个标志记录并把左边记录。i&1————判断奇偶
#include<cstdio>
#include<iostream>
using namespace std;
bool a[6][6] = {0};
bool flag;
int step;
int in[40];
int dex;

bool judge_all()
{
    for(int i = 1; i <= 4; i++){
        for(int j = 1; j <=4;j++){
                if(a[i][j])
                  return false;
        }
    }
    return true;
}
void flip(int row,int col)
{
    for(int i = 1; i <= 4; i++){
            a[row][i] = !a[row][i];
            a[i][col] = !a[i][col];
    }
    a[row][col] = !a[row][col];
}
void dfs(int row, int col, int deep)
{
    if(deep == step){
            flag = judge_all();
            return ;
    }
    if(flag||row == 5) return ;
    flip(row,col);
    if(col < 4)
        dfs(row,col + 1, deep + 1);
    else dfs(row + 1, 1,deep + 1);
    flip(row , col);
    if(flag){
            in[dex] = row;
            in[dex+1] = col;
            dex += 2;
    }
    if(col < 4)
        dfs(row, col + 1,deep);
    else dfs(row + 1, 1, deep);
    return ;
}
int main()
{
    char x;
    for(int i = 1; i <= 4; i ++){
        for(int j = 1; j < 5; j++){
                cin>>x;
        if(x == '+')
            a[i][j] = 1;
        }
    }
    for(step = 1;step <= 16;step++){
            dex = 1;
           dfs(1,1,0);
           if(flag)
            break;
    }
    printf("%d\n",step);
    for(int i = step*2;i>=1;i--){
            if(i&1)
            printf("%d %d\n",in[i],in[i+1]);
    }
    return 0;
}
View Code

 

 

转载于:https://www.cnblogs.com/zero-begin/p/4313129.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值