The Pilots Brothers' refrigerator(POJ 2965)(dfs枚举+状态压缩)

题目链接:http://poj.org/problem?id=2965
Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+–


-+–
Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

思路:思路和POJ1753差不多,可以翻我的博客看那篇文章,这里就不赘述了。和上一道题不同的地方就是这道题要记录路径,所以,分别用两个数组row,col来记录路径上的点的行号和列号,要输出的时候,直接把这两个数组输出一下就好了。还用了状态压缩,状态压缩的方式可以看我的一个有关二进制的博客。

二进制:http://blog.csdn.net/Ema1997/article/details/53510597
POJ 1753:http://blog.csdn.net/ema1997/article/details/53418059

思考:
1、可以用两个数组来记录路径

#include <iostream>
#include <queue>
#include <stack>
#include <cstring>

using namespace std;

int row[20], col[20];
int step;
bool flag = false;

void flip(int i, int &state)
{
    state ^= (1 << i);
    for (int j = 0; j < 4; j++) {
        state ^= (1 << (i / 4 * 4+ j));
    }
    for (int j = 0; j < 4; j++) {
        state ^= (1 << (i % 4 + 4 * j));
    }
}

void dfs (int &state, int deep, int i)
{
    if (deep == step) {
        if (state == 0) flag = true;
        return;
    }
    if (i >= 16 || flag) return;

    flip (i, state);
    int k = 15 - i;
    row[deep] = k / 4 + 1;
    col[deep] = k % 4 + 1;

    dfs (state, deep + 1, i + 1);
    if (flag) return;

    flip (i, state);
    dfs (state, deep, i + 1);
}

int main()
{
    int state = 0;
    for (int i = 0; i < 16; i++) {
        char c;
        cin >> c;
        state <<=  1;
        if (c == '+') {
            state |= 1;
        }
    }
    memset (row, 0, sizeof(row));
    memset (col, 0, sizeof(col));
    for (step = 0; step < 17; step++) {
        dfs (state, 0, 0);
        if (flag) break;
    }
    cout << step << endl;
    for (int i = 0; i < step; i++) {
        cout << row[i] << " " << col[i] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值