POJ 1703 Find them, Catch them【带种类的并查集】

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.


题意:就是有两个犯罪团伙,A组给出的x, y而是表明他们不是一伙的.
思路:在原来裸并查集的基础上,多了一个rank[]数组,存放的是father[a]与a的关系,0表示不在一伙,1表示在一伙。father[a]存a的根节点。在状态压缩是也更改rank[]的值为类别转移.
代码如下:
View Code
#include<stdio.h>
#include<string.h>
#define N 100005
int father[N], rank[N];
int find(int x)
{
    if(x==father[x])
        return x;
    int t=father[x];
    father[x]=find(t);
    rank[x]=(rank[t]+rank[x])%2;
    return father[x];
} 
int main()
{
    int i, j, k, n, m, T, x, y;
    char ch; 
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        getchar(); 
        for(i=1; i<=n; i++)
            father[i]=i, rank[i]=0;
        for(i=0; i<m; i++)
        {
            scanf("%c%d%d", &ch, &x, &y);
            getchar();
            if(ch=='A')
            {
                if(n==2)    //特殊处理 
                {
                    if(x==y)    printf("In the same gang.\n"); 
                    else    printf("In different gangs.\n");
                    continue; 
                }
                int xx=find(x), yy=find(y);
                if(xx==yy)
                {
                    if(rank[x]==rank[y])    printf("In the same gang.\n");
                    else    printf("In different gangs.\n");
                }
                else
                    printf("Not sure yet.\n");
            }
            else
            {
                int xx=find(x), yy=find(y);
                father[yy]=father[xx];
                rank[yy]=(rank[x]+1+2-rank[y])%2; //类别偏移 
            }
        }
    }
}    
             

 



转载于:https://www.cnblogs.com/Hilda/archive/2012/08/04/2623408.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值