Find them, Catch them

25 篇文章 0 订阅

Find them, Catch them
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Appoint description: System Crawler  (2018-07-10)

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

根据判断集团之间的老大是否有敌对关系来确定 成员之间的关系


#include<cstdio>
int d[100000];
int f[100000];
int find(int x)
{
	if(x!=f[x])
	{
		f[x]=find(f[x]);
	}
	return f[x];
}
void  u(int x,int y)
{
	int a=find(x);
	int b=find(y);
	if(a!=b)
	{
		f[a]=b;
	}
}
/*****以上标准并查集 ****/ 

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		for(int i=0;i<=n;i++)//初始化 
		{
			d[i]=0;
			f[i]=i;
		}
		while(m--) 
		{
			char c;
			int x,y;
			scanf(" %c%d%d",&c,&x,&y);
			if(c=='A')
			{
				if(find(x)==find(y))
				{
					printf("In the same gang.\n");
				}
				else if(d[find(x)]==find(y)&&d[find(x)]!=0) {//判断集团 x 的老大和集团 y 的老大是否有敌对关系 
					printf("In different gangs.\n");
				}
		  		else printf("Not sure yet.\n");
			}
			else {
				 int a=find(x);  //找到x的老大  a 
				 int b=find(y); // 找到y的老大  b 
				if(d[a]>0)   //如果老大 a 有敌对的集团老大 
				{
					u(y,d[a]); //那么就把 b 加入到敌对老大的集团 
				}
				if(d[b]>0)  //同理 
				{
					u(x,d[b]);
				}
				 a=find(a); //由于集团合并,老大可能易主 ,所以要重新找老大 
				 b=find(b);
				d[a]=b;  //确定老大之间的敌对关系 
				d[b]=a;
			}
		}
	}
}

看了学弟的代码,发现更精辟的写法,学习学习!!!!!!

#include <iostream>
#include <algorithm>
using namespace std;
int pre[200000];
int find(int x){
	if(pre[x]==x)
		return x;
	else 
		return pre[x]=find(pre[x]);
}
void men(int x,int y){
	int a=find(x),b=find(y);
	if(a!=b)
		pre[a]=b;
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m;
		scanf("%d %d",&n,&m);
		char c;
		int x,y;
		for(int i=0;i<=2*n;i++){
			pre[i]=i;
		}
		getchar();
		for(int i=0;i<m;i++){
			scanf("%c %d %d",&c,&x,&y);
			getchar();
			if(c=='A'){
				if(find(x)==find(y+n) && find(x+n)==find(y))
					printf("In different gangs.\n");
				else if(find(x)==find(y))
					printf("In the same gang.\n");
				else{
					printf("Not sure yet.\n");
				}
			}
			else{
				men(x,y+n);     // y+n 简单理解就是敌人的映射,和敌人的映射建立关系,如果下面出现相同的敌人映射关系,就间接的合并了朋友关系 
				men(x+n,y);
			}
		}
	}
}




  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值