Find them, Catch them(种类并查集)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42442 Accepted: 13056

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

/*
如果父亲和孩子是同一个团伙,那么孩子标记为0,如果不是的话,孩子标记为1
在一个集合里的证明他们之间有关系,种类里有0,和1两种。0代表着同父节点相同势力,1代表不同
*/
#include<stdio.h>
#define maxn 100010
int r[maxn];//存与根节点的关系,0 代表同类, 1代表不同类 
int f[maxn];//存父亲节点 
void init(int n)
{
    for(int i=1;i<=n;i++)
    {
        f[i]=i;//自己是自己的父节点 
        r[i]=0;//自己和自己属于同一类  
    }
}
int findroot(int x)
{
    if(x==f[x])
        return x;
    int tmp=f[x];//记录父亲节点 方便下面更新r[]  
    f[x]=findroot(f[x]);  
    r[x]=(r[x]+r[tmp])%2;//根据子节点与父亲节点的关系和父节点与爷爷节点的关系,推导子节点与爷爷节点的关系
    return f[x];
}
void join(int x,int y)
{
    int dx=findroot(x);
    int dy=findroot(y);

    f[dx]=dy;
    // //经观察,当2个节点相对于父节点的性质都是true或都是false时,两个父节点不是同伙,反之是同伙 
    r[dx]=!(r[x]^r[y]);// r[dx]=(r[x]+r[y]+1)%2;
}
int main()
{
    int t;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        char s[10];
        int a,b;
        int n,m;
        scanf("%d%d",&n,&m);
        init(n);
        for(i=0;i<m;i++)
        {
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='D')
            {
                join(a,b);
            }
            else
            {
                if(findroot(a)==findroot(b))
                {
                     if(r[a]==r[b])
                     {
                         printf("In the same gang.\n");
                     }
                     else
                        printf("In different gangs.\n");
                }
                else
                    printf("Not sure yet.\n");
            }
        }

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值