ACM YTU 挑战编程 字符串 Problem A: WERTYU

Problem A: WERTYU



Description

A common typing error is to place yourhands on the keyboard one row to the right of the correct position. Then ``Q'' is typed as ``W'' and ``J'' is typed as ``K'' and so on. Your task is to decode a message typed inthis manner.


Input

Input consists ofseveral lines of text. Each line may contain digits, spaces, uppercase letters(except ``Q'', ``A'', ``Z''), or punctuation shown above [except back-quote(`)]. Keys labeled with words [Tab, BackSp, Control, etc.] are not representedin the input.


Output

You are to replaceeach letter or punctuation symbol by the one immediately to its left on theQWERTY keyboard shown above. Spaces in the input should be echoed in theoutput.


Sample Input

O S, GOMR YPFSU/


Sample Output

I AM FINE TODAY.

 
     
 
 
     
 
     
/**
*   水题
*   提议就是输入一串字符,输出它在 键盘上前一位的字符  如  输入U  输出的就是Y
*   ps:QAZ除外   空格原样输出
*
*/
#include <iostream>
using namespace std;
int main()
{
    string s = "`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
    string line;
    while(getline(cin,line))
    {
        for(int i = 0;i<int(line.length());i++)
        {
            if(line[i]==' ')
                cout<<" ";
            else
                cout<<s[s.find_first_of(line[i])-1];
/**
*   string 类的一个成员函数
*   s.find_first_of(line[i])
*   找到 line[i] 在(string)s中出现的第一个值并返回(返回类型为int),没有就返回如果没找到就返回string::npos
*   详情参考 http://blog.163.com/chen_dawn/blog/static/1125063201111191617784/
*/
        }
        cout<<endl;
    }
    return 0;
}

posted on 2013-08-10 11:43  CY_ 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/gray1566/p/3704307.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值