ACM HDU 2674 N! Again(数论)

继续数论。。


Problem Description

WhereIsHeroFrom:            Zty,what are you doing ?
Zty:                                    Iwant to calculate N!......
WhereIsHeroFrom:            Soeasy! How big N is ?
Zty:                                    1<=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:            Oh! Youmust be crazy! Are you Fa Shao?
Zty:                                    No.I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!

 

Input

Each linewill contain one integer N(0 <= N<=10^9). Process to end of file.

 

Output

For eachcase, output N! mod 2009

 

Sample Input

4 
5

 

 

Sample Output

24
120
 
    


/*****************************************************

数据规模  1<N<10^9,妥妥的要找规律了。。


从  N = 1  到N = 40  时还都能正常算出,(正常规律  num[i] = num[i-1] * i %2009;  (   1<N<10^9),,,N 为40时,num[N] = 245,可以发现  245 * 41 = 10045 = 2009 * 5,

所以,就可以知道了,N>40时,输出全部为  0。。。

***********************************************************/


#include<stdio.h>
#include<iostream>
using namespace std;
int num[42];
void cal()
{
	num[0] = 1,num[1] = 1;
	for(int i = 2;i<42;i++)
		num[i] = num[i-1]*i%2009;
}
int main()
{

	int n;
	cal();
	while(cin>>n)
    {
        if(n>41)
            printf("%d\n",0);
        else
            printf("%d\n",num[n]);
    }
	return 0;
}


posted on 2014-03-28 21:22  CY_ 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/gray1566/p/3704296.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值