UVA 10061 How many zero's and how many digits ?


Problem G

How many zeros and how many digits?

Input: standard input

Output: standard output


Given a decimal integer number you will have to find out how many trailing zeros will be there in its factorial in a given number system and also you will have to find how many digits will its factorial have in a given number system? You can assume that for a b based number system there are b different symbols to denote values ranging from 0 ... b-1.


Input

There will be several lines of input. Each line makes a block. Each line will contain a decimal number N (a 20bit unsigned number) and a decimal number B (1<B<=800), which is the base of the number system you have to consider. As for example 5! = 120 (in decimal) but it is 78 in hexadecimal number system. So in Hexadecimal 5! has no trailing zeros


Output

For each line of input output in a single line how many trailing zeros will the factorial of that number have in the given number system and also how many digits will the factorial of that number have in that given number system. Separate these two numbers with a single space. You can be sure that the number of trailing zeros or the number of digits will not be greater than 2^31-1


Sample Input:

2 10
5 16
5 10

 

Sample Output:

0 1
0 2
1 3
________________________________________________________________________________________ 
Shahriar Manzoor
16-12-2000


如果求B进制的数,先将N的阶乘求出来,然后Log(B)N在加上一就是位数。如果求末尾有多少零,就要看是多少进制的数,如果是十进制的就是看有多少对2*5.

#include<stdio.h>
#include<math.h>
#include<string.h>
int z[100007];

int ndigit(int nn,int bb)//求位数
{
    double sum=0.0;
    for(int i=2;i<=nn;i++)//求N的阶乘
    {
         sum+=log10(i);
    }
    sum/=log10(bb);
    return floor(sum+1e-9)+1;//精度问题
}

int nzero(int nn,int bb)//求末尾有多少个零
{
   for(int i=2;i<=nn;i++)//分解每个因子
   {
       int flag=i;
       for(int j=2;j<=flag&&j<=bb;j++)
       {
           while(flag%j==0)
           {
               z[j]++;
               flag/=j;
           }
       }
   }
   int count=0;
   while(1)//求末尾零
   {
       int flag1=bb;
       for(int k=2;k<=flag1;k++)
       {
           while(flag1%k==0)
           {
               if(z[k]>0)
               {
                   z[k]--;
               }
               else goto end;
               flag1/=k;
           }
       }
       count++;
   }
   end:
   return count;
}

int main()
{
    int n,b;
    while(scanf("%d%d",&n,&b)!=EOF)
    {
        memset(z,0,sizeof(z));
        int digit=ndigit(n,b);
        int zero=nzero(n,b);
        printf("%d %d\n",zero,digit);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值