HDU 2612

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5974    Accepted Submission(s): 1995


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88

66

分别以Y和M为起点,进行两次BFS,然后取最小的到@的步数和即可。由于本人的粗心,在循环控制时将m写成n,结果卡了一个小时,惨痛的教训

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;

typedef pair <int, int> P;
const int INF = 10000000;
int n, m;
int dx[] = {-1, 0, 1, 0}, dy[] = {0, 1, 0, -1};
char s[210][210];
void bfs(int x, int y, int d[210][210])
{
    queue <P> que;
    fill(d[0], d[0] + 210 * 210, INF);
    que.push(P(x, y));
    d[x][y] = 0;

    while(! que.empty())
    {
        P p = que.front(); que.pop();

        for(int i = 0; i < 4; i++)
        {
            int nx = p.first + dx[i], ny = p.second + dy[i];
            if(nx >= 0 && nx < n && ny >= 0 && ny < m &&  s[nx][ny] != '#' && d[nx][ny] == INF)
            {
                que.push(P(nx, ny));
                d[nx][ny] = d[p.first][p.second] + 1;
            }
        }
    }
}

int main()
{
    int x1, y1, x2, y2;
    int d1[210][210], d2[210][210];

    while(~ scanf("%d%d", &n, &m))
    {
        for(int i = 0; i < n; i++)
        {
            scanf(" %s", s[i]);
            for(int j = 0; s[i][j]; j++)
            {
                if(s[i][j] == 'Y') x1 = i, y1 = j;
                if(s[i][j] == 'M') x2 = i, y2 = j;
            }
        }

        bfs(x1, y1, d1);
        bfs(x2, y2, d2);

        int res = 10000000;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                if(s[i][j] == '@' && d1[i][j] != INF && d2[i][j] != INF)
                    res = min(res, d1[i][j] + d2[i][j]);

        printf("%d\n", res * 11);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值