HDU 1533 && POJ 2195 Going Home 最小费用流模板题

Going Home

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3647    Accepted Submission(s): 1873


Problem Description
On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.
 

Input
There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.
 

Output
For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay. 
 

Sample Input
  
  
2 2 .m H. 5 5 HH..m ..... ..... ..... mm..H 7 8 ...H.... ...H.... ...H.... mmmHmmmm ...H.... ...H.... ...H.... 0 0
 

Sample Output
  
  
2 10 28
//最小费用流第三题
//题意就是同等个数的m和H,让每个m走到H里,每步花费1,求最小的花费
//首先预处理图,分离出m和H,然后从超级源点向每个m连边,容量1,花费0,从每个H向超级汇点连边,容量1,花费0,从每个m向每个H连边,容量1,花费为它们之间的步数,然后套模板求出最小费用流即是答案
//此题是个简单题,嗯,简单模板题
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;

const int N = 110;
const int INF = 0x3f3f3f3f;
char mpa[N][N];
int n, m;

struct edge
{
    int to, cap, cost, rev;
};
struct node
{
    int x, y;
}s1[N], s2[N];

vector <edge> G[N*5];
int prevv[N*5], preve[N*5];
int dist[N*5];
bool used[N*5];

void add_edge(int from, int to, int cap, int cost)
{
    edge e;
    e.to = to, e.cap = cap, e.cost = cost, e.rev = G[to].size();
    G[from].push_back(e);
    e.to = from, e.cap = 0, e.cost = -cost, e.rev = G[from].size() - 1;
    G[to].push_back(e);
}

int min_cost_flow(int s, int t, int f)
{
    int res = 0;
    while(f > 0)
    {
        memset(used, 0, sizeof used);
        memset(dist, 0x3f, sizeof dist);

        queue <int> que;
        que.push(s);
        dist[s] = 0;
        used[s] = true;

        while(! que.empty())
        {
            int v = que.front(); que.pop();

            for(int i = 0; i < G[v].size(); i++)
            {
                edge &e = G[v][i];
                if(e.cap > 0 && dist[e.to] > dist[v] + e.cost)
                {
                    dist[e.to] = dist[v] + e.cost;
                    prevv[e.to] = v;
                    preve[e.to] = i;
                    if(! used[e.to])
                    {
                        que.push(e.to);
                        used[e.to] = true;
                    }
                }
            }
            used[v] = false;
        }

        if(dist[t] == INF) return -1;

        int d = f;
        for(int i = t; i != s; i = prevv[i])
            d = min(d, G[prevv[i]][preve[i]].cap);

        f -= d;
        res += d * dist[t];
        for(int i = t; i != s; i = prevv[i])
        {
            edge &e = G[prevv[i]][preve[i]];
            e.cap -= d;
            G[i][e.rev].cap += d;
        }
    }
    return res;
}

int main()
{
    while(scanf("%d%d", &n, &m), n || m)
    {
        for(int i = 0; i < n; i++)
            scanf(" %s", mpa[i]);

        int cnt1 = 0, cnt2 = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
                if(mpa[i][j] == 'm')
                    s1[cnt1].x = i, s1[cnt1].y = j, cnt1++;
                else if(mpa[i][j] == 'H')
                    s2[cnt2].x = i, s2[cnt2].y = j, cnt2++;

        for(int i = 0; i < cnt1; i++)
            add_edge(0, i + 1, 1, 0);
        for(int i = 0; i < cnt2; i++)
            add_edge(cnt1 + i + 1, cnt1 + cnt2 + 1, 1, 0);

        for(int i = 0; i < cnt1; i++)
            for(int j = 0; j < cnt2; j++)
                add_edge(i + 1, cnt1 + j + 1, 1, abs(s1[i].x - s2[j].x) + abs(s1[i].y - s2[j].y));

        printf("%d\n", min_cost_flow(0, cnt1 + cnt2 + 1, cnt1));
        for(int i = 0; i <= cnt1 + cnt2 + 1; i++)
            G[i].clear();
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值