HDU 4950 Monster (水题)

Monster

题目链接:

http://acm.hust.edu.cn/vjudge/contest/123554#problem/I

Description


Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.
Monster initially has h HP. And it will die if HP is less than 1.
Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.
After k consecutive round's attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.
Output "YES" if Teacher Mai can kill this monster, else output "NO".

Input


There are multiple test cases, terminated by a line "0 0 0 0".
For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).

Output


For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".

Sample Input


5 3 2 2
0 0 0 0

Sample Output


Case #1: NO


题意:


怪物有h点血,每回合可以打a点,打完如果没死可以恢复b点.
每k轮至少休息一次. 求是否能打死怪物.


题解:


考虑长远的情况肯定是 ak - b(k+1) > 0 ?.
但是还有一些特殊一点的情况:
如果一次就能打死怪物,即 a >= h , 无论b多大都不影响.
贪心的思路肯定是在第k+1轮才休息. 那么在休息之前能打死,那在休息之后可能就不满足上述不等式.
即 ak - b(k-1) >= h
WA了一发:如果第k轮打死,怪物是不会回血的,所以是减去b*(k-1).
水题也还须考虑全面. 切忌盲目提交.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <vector>
#define LL long long
#define eps 1e-8
#define maxn 101000
#define mod 100000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;


int main(int argc, char const *argv[])
{
    //IN;

    LL h,a,b,k;
    int ca = 1;
    while(scanf("%lld %lld %lld %lld", &h,&a,&b,&k) != EOF && (h||a||b||k))
    {
        if(a >= h) printf("Case #%d: YES\n", ca++);
        else if(a*k-b*(k-1) >= h) printf("Case #%d: YES\n", ca++);
        else if(a*k-b*(k+1) > 0) printf("Case #%d: YES\n", ca++);
        else printf("Case #%d: NO\n", ca++);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5750725.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值