POJ 1847 Tram (最短路)

Tram

题目链接:

http://acm.hust.edu.cn/vjudge/contest/122685#problem/N

Description


Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.
When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.
Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input


The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.
Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output


The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input


3 2 1
2 2 3
2 3 1
2 1 2

Sample Output


0

Hint



题意:


求图中#A到#B的最短路.


题解:


裸的最短路,数据非常小,随便求就好.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <vector>
#define LL long long
#define eps 1e-8
#define maxn 110
#define mod 1000000007
#define inf 0x3f3f3f3f
#define IN freopen("in.txt","r",stdin);
using namespace std;

int n,s,t;
int dis[maxn][maxn];

void init() {
    for(int i=1; i<=n; i++)
        for(int j=1; j<=n; j++)
            dis[i][j] = (i==j? 0:inf);
}

void floyd() {
    for(int k=1; k<=n; k++)
    for(int i=1; i<=n; i++)
    for(int j=1; j<=n; j++)
        if(dis[i][j] > dis[i][k]+dis[k][j])
            dis[i][j] = dis[i][k] + dis[k][j];
}

int main(void)
{
    //IN;

    while(scanf("%d %d %d", &n,&s,&t) != EOF)
    {
        init();
        for(int i=1; i<=n; i++) {
            int m; scanf("%d", &m);
            for(int j=1; j<=m; j++) {
                int x; scanf("%d", &x);
                dis[i][x] = j==1? 0:1;
            }
        }

        floyd();


        if(dis[s][t] == inf) printf("-1\n");
        else printf("%d\n", dis[s][t]);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5751555.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值