HDU 5832 A water problem (带坑水题)

A water problem

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5832

Description


Two planets named Haha and Xixi in the universe and they were created with the universe beginning.
There is 73 days in Xixi a year and 137 days in Haha a year.
Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input


There are several test cases(about 5 huge test cases).
For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output


For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

Sample Input


10001
0
333

Sample Output


Case #1: YES
Case #2: YES
Case #3: NO

Source


2016中国大学生程序设计竞赛 - 网络选拔赛


题意:


判断一个长度最多为1e7的数串是否同时模73和137为0.


题解:


第一眼反应是水题,赶紧用java打一发. 结果MLE...
然后用getchar逐个读入判断. TLE.
才反应过来要用gets或scanf读入再处理,直到第四发才过...


比赛中java一定要慎用,如果能看别人的提交信息,先看看用java有没有过的.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 10001000
#define mod 1000000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

char str[maxn];

int main(int argc, char const *argv[])
{
    //IN;

    int ca = 1;
    while(gets(str))
    {
        int num = 0;
        int sz = strlen(str);

        for(int i=0; i<sz; i++) {
            num = (num*10 + str[i] - '0') % 10001;
        }

        if(num) printf("Case #%d: NO\n", ca++);
        else printf("Case #%d: YES\n", ca++);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5770519.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值