A water problem HDU - 5832 (大位数取模)

Two planets named Haha and Xixi in the universe and they were created with the universe beginning. 

There is 7373 days in Xixi a year and 137137 days in Haha a year. 

Now you know the days NN after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 55 huge test cases). 

For each test, we have a line with an only integer N(0≤N)N(0≤N), the length of NN is up to 1000000010000000.

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

Sample Input

10001
0
333

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

 

问题分析:

    (1)大数存储:由于x的位数最大为400位,我们不能用现有的int,long,long long,double等数据类型进行存储。一般存储大数的方法是用一个字符串来表示。

    (2)取模运算:模拟手算竖式的方法。用x从高到低的每一位加上前一位余数*10来对bi进行%,最后得到的结果就是x%bi的结果。

    利用到公式:(a+b) mod (n) = (a mod n) + (b mod n) mod (n);

  1 %m   =  1 
        12 % m  = ( 1 * 10 + 2 ) % m = ( 1 % m * 10 + 2 ) % m 
        123 % m = ( 12 * 10 + 3) % m = ( 12 % m * 10 + 3) % m 

        ...
       12345678901234567890 % m =(( 1 % m * 10 + 2 ) % m * 10 + 3 ) % m...

 

int divMod(char* ch,int num)
{
	int s = 0;
	for(int i=0;ch[i]!='\0';i++)
		s = (s*10+ch[i]-'0')%num;
	
	return s;
}

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char a[10000007];
int main()
{
    int cas = 1;
    while(~scanf("%s",a))
    {
        int mod = 0;
        for(int i = 0; i < strlen(a); i++)
        {
            mod=(mod*10+a[i]-'0')%(73*137);
        }
        if(mod == 0)
            printf("Case #%d: YES\n",cas++);
        else
            printf("Case #%d: NO\n",cas++);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值