HDU 5867 Water problem (模拟)

Water problem

题目链接:

http://acm.split.hdu.edu.cn/showproblem.php?pid=5867

Description


If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?
Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.

Input


There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.
For each test case: There is one positive integer not greater one thousand.

Output


For each case, print the number of letters would be used.

Sample Input


3
1
2
3

Sample Output


3
6
11

Source


2016 Multi-University Training Contest 10


题意:


求 1~n 这n个数字的英文写法的总长度. (不算空格和连字符)


题解:


对特殊的情况进行预处理即可.
1~19的英文单词是特殊情况. 20 30 ... 整十是特殊情况. 1000也是特殊情况.
其他的就是由上述单词组合得到. 注意整百时是没有"and"的.
注意细节处理即可.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 110
#define mod 100000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int gewei[] = {4,3,3,5,4,4,3,5,5,4,3,6,6,8,8,7,7,9,8,8};
int shiwei[] = {0,0,6,6,5,5,5,7,6,6};
int hund, thou;
int cnt[1100];

int main(int argc, char const *argv[])
{
    //IN;

    hund = 7; thou = 8;

    cnt[1000] = 11;
    for(int i=1; i<1000; i++) {
        if(i < 20) cnt[i] = gewei[i];
        else if(i < 100){
            int m = i;
            cnt[i] = shiwei[m/10];
            if(m%10) cnt[i] += gewei[m%10];
        }
        else {
            int m = i;
            cnt[i] = gewei[m/100] + hund;
            if(!(m%100)) continue;
            cnt[i] += cnt[m%100] + 3;
        }
    }

    for(int i=1; i<=1000; i++)
        cnt[i] += cnt[i-1];

    int t; cin >> t;
    while(t--)
    {
        int n; scanf("%d", &n);

        printf("%d\n", cnt[n]);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5784690.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值