A water problem(大数取模)

A water problem

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3124 Accepted Submission(s): 1126

Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output
For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input
10001
0
333

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO

一定要注意,题目给的是N的长度,一看就知道使用字符串~
题意是看看这个数能不能同时被137和73整除,他俩的最小公倍数是10001,所以取模10001就可以了!

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char n[10000001];
int main()
{
    int t = 1;
    while(~scanf("%s", n))
    {
        int len = strlen(n);
        int v = 0;
        for(int i=0;i<len;i++)//字符串转化的取模运算
        {
            v = (v*10 + n[i]-'0') % 10001;
        }
        if(v==0)
            cout<<"Case #"<<t<<": "<<"YES"<<endl;
        else
            cout<<"Case #"<<t<<": "<<"NO"<<endl;
        t++;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值