最小生成树: HDU1233还是畅通工程


还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47015    Accepted Submission(s): 21448


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
 
      
3
1 2 1
1 3 2
4
2 3 4
1 2 1
2 3 3
1 3 4 1 4 1 2 4 2
0
3 4 5
 

Sample Output
 
      
3
5
Hint
Hint
Huge input, scanf is recommended.
Problem : 1233 ( 还是畅通工程 )     Judge Status : Accepted RunId : 21246904    Language : G++    Author : hnustwanghe Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
#include<iostream> #include<cstring> #include<cstdio> #include<queue> using namespace std; const int N = 100 + 5; typedef struct node{ int from,to,val; node(int from=0,int to=0,int val=0):from(from),to(to),val(val){} bool operator < (const node x)const { return val > x.val; } }Node; int pre[N]; int Find(int x){ return pre[x]==x?x:(pre[x]=Find(pre[x])); } bool Merge(int x,int y){ x = Find(x),y = Find(y); if(x!=y) pre[x] = y; return x!=y?true:false; } priority_queue<Node> Q; int Kruskal(int n){ Node t; int tmp = n*(n-1)/2,a,b,val,ans=0,cnt=0; for(int i=1;i<=tmp;i++){ scanf("%d %d %d",&a,&b,&val); Q.push(Node(a,b,val)); } while(!Q.empty()){ t = Q.top();Q.pop(); if(Merge(t.from,t.to)){ ans += t.val; cnt++; if(cnt == n-1) return ans; } } return ans; } int main(){ int n; while(scanf("%d",&n)==1 && n){ while(!Q.empty()) Q.pop(); for(int i=0;i<N;i++) pre[i] = i; printf("%d\n",Kruskal(n)); } }
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>

using namespace std;
const int N = 100 + 5;
typedef struct node{
    int from,to,val;
    node(int from=0,int to=0,int val=0):from(from),to(to),val(val){}
    bool operator < (const node x)const {
        return val > x.val;
    }
}Node;
int pre[N];

int Find(int x){
    return pre[x]==x?x:(pre[x]=Find(pre[x]));
}

bool Merge(int x,int y){
    x = Find(x),y = Find(y);
    if(x!=y) pre[x] = y;
    return x!=y?true:false;
}
priority_queue<Node> Q;

int Kruskal(int n){
    Node t;
    int tmp = n*(n-1)/2,a,b,val,ans=0,cnt=0;
    for(int i=1;i<=tmp;i++){
        scanf("%d %d %d",&a,&b,&val);
        Q.push(Node(a,b,val));
    }
    while(!Q.empty()){
        t = Q.top();Q.pop();
        if(Merge(t.from,t.to)){
            ans += t.val;
            cnt++;
            if(cnt == n-1) return ans;
        }
    }
    return ans;
}
int main(){
    int n;
    while(scanf("%d",&n)==1 && n){
        while(!Q.empty()) Q.pop();
        for(int i=0;i<N;i++) pre[i] = i;
        printf("%d\n",Kruskal(n));
    }
}

转载于:https://www.cnblogs.com/Pretty9/p/7347708.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值