[HDOJ#1006]Tick and Tick

Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 
Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 
Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 
Sample Input
0
120
90
-1
 
Sample Output
100.000
0.000
6.251
 
#include <cstdio>
#include <iostream>
 using namespace std;
 double max1(double a,double b,double c){
     if(a<b) a=b;
     if(a<c) a=c;
     return a;
 }
 double min1(double a,double b,double c){
     if(a>b) a=b;
     if(a>c) a=c;
     return a;
 }
 inline bool equal1(double a,double b){
     if((a-b)>-0.0000001&&(a-b)<0.0000001) return true;
     else return false;}
 int main(){
     double sum=0.0,d,newx,newy;
     double mh=43200.0000/11;
     double sm=3600.0000/59;
     double sh=43200.0000/719;
     double dsm,dsh,dmh,tdsm,tdsh,tdmh;
     while(scanf("%lf",&d)&&d!=-1){
         sum=0.0;
           dsm=    10.0*d/59.0;  tdsm=sm-dsm;
           dsh=    120.0*d/719.0;     tdsh=sh-dsh;
           dmh=    120.0*d/11.0;     tdmh=mh-dmh;
           newx=max1(dsm,dsh,dmh); newy=min1(tdsm,tdsh,tdmh);
           while(newx<=43200&&newy<=43200){
               newx=max1(dsm,dsh,dmh);          
               newy=min1(tdsm,tdsh,tdmh);       //cout<<newx<<" "<<newy; Sleep(1000);
               if(newx<newy) sum+=newy-newx; //cout<<" "<<sum<<" ";Sleep(1000);
               if(newy==tdsm) {dsm+=sm;tdsm+=sm;}
               else if(newy==tdsh) {dsh+=sh;tdsh+=sh;}
               else if(newy==tdmh){dmh+=mh;tdmh+=mh;}
           }
           printf("%.3lf\n",sum/432);}
           return 0;
 }

 

转载于:https://www.cnblogs.com/gyhua96/articles/4494738.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值