[HDOJ#1009]FatMouse' Trade

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500
 
 
My solution:
 
#include<iostream>
#include<algorithm>
#include<iomanip>
using namespace std;
typedef struct Pecent
{
    double a;
    double b;
    double p;
} node;

int main(void)
{
    int m,n;
    Pecent pe[1001];
    double ob;
    while (cin>>m>>n)
    {
        ob=0.0;
        if (m<0) break;
        for (int i=0;i<n;i++)
        {
            cin>>pe[i].a>>pe[i].b;
            pe[i].p=pe[i].a/pe[i].b;
        }
    bool cmp(const node a,const node b);
    sort(pe,pe+n,cmp);
    for (int i=0;i<n&&m>=0;i++)
    {        
        if (m<pe[i].b&&m>0)
        {
            ob+=1.0*m/pe[i].b*pe[i].a; 
            m=0;
        }
        if (m>=pe[i].b) 
        {
            m-=pe[i].b;
            ob+=pe[i].a;
        }

    }
    cout<<setiosflags(ios::fixed)<<setprecision(3)<<ob<<endl;
    }
    return 0;
}
bool cmp(const node a,const node b)
{
    return a.p>b.p;
}

 

转载于:https://www.cnblogs.com/gyhua96/articles/4494756.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值