poj-2393-Yogurt Factory

 

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

题目大意:在接下来N周之内,Yucky Yogurt需要在第i周花C_i的钱生产一个单位的牛奶。牛奶可以无限多,且不会变质,可以存到以后再卖。每一周需对每个单位的牛奶支付S元以保存。第i周需要Y_i个单位的牛奶。求最小支出。

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 

 

 

 

还是贪心。主观上可以得出这么一个结论:要让最低的一个价格乘这周的价格(显然要么全部在这周生产,要么全部用之前某一周的)。

 

 

 

 

于是,下为代码。

 

#include<cstdio>
#define min(a,b) (a)<(b)?(a):(b)
int n,s,c2,y;
long long c1,ans;
int main()
{
	int i;
	scanf("%d%d",&n,&s);
	for(i=1;i<=n;i++)
	{
		scanf("%d%d",&c2,&y);
		if(i==1) c1=c2;
		else c1=min(c1+s,c2);
		ans+=c1*y;
	}
	printf("%lld\n",ans);
}

 

 

至于那个define..........很久以前从学校OJ的某大神的代码中看到然后神不知鬼不觉就开始用了........

(也可以用iostream还是algorithm中哪个头文件(我忘了)里的max/min函数)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值