Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
   

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <vector>
#include <bitset>
#include <cstdio>
#include <string>
#include <numeric>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <functional>
using namespace std;
typedef long long  ll;
typedef unsigned long long ull;

int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1};//up down left right
bool inmap(int x,int y,int n,int m){if(x<1||x>n||y<1||y>m)return false;return true;}
int hashmap(int x,int y,int m){return (x-1)*m+y;}

#define eps 1e-8
#define inf 0x7fffffff
#define debug puts("BUG")
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define read freopen("in.txt","r",stdin)
#define write freopen("out.txt","w",stdout)
#define lowbit(x) (-x)&x
#define maxn 500050

/**树状数组**/
struct A
{
    int id,s;
}a[maxn];
int m[maxn];
long long sum[maxn];
int N;

bool cmp(A a,A b)
{
    return a.s<b.s;
}

void init()//初始化
{
    memset(sum,0,sizeof(sum));
    memset(a,0,sizeof(a));
    memset(m,0,sizeof(m));
}

void change(int x)//树状数组插入
{
    while(x<=N)
    {
        sum[x]++;
        x+=lowbit(x);
    }
}

long long query(int x)//树状数组查询
{
    long long ans=0;
    while(x>0)
    {
        ans+=sum[x];
        x-=lowbit(x);
    }
    return ans;
}

int main()
{
    while(scanf("%d",&N)!=EOF&&N)
    {
        init();
        for(int i=0;i<N;i++)
        {
            scanf("%d",&a[i].s);
            a[i].id=i;
        }
        sort(a,a+N,cmp);//由于所给的点跨度太大,所以要进行离散化,只需要保留原数据的大小关系即可

        for(int i=0;i<N;i++)
        {
            m[a[i].id]=i+1;//如此,原数据全部变成了从1~N的正整数,大小关系不变
        }

        long long ans=0;
        for(int i=0;i<N;i++)
        {
            ans+=i-query(m[i]);//每次查询的是m[i]前面有多少个数,用已经插入的数的个数减去这个数,就是逆序对数
            change(m[i]);//插入当前数字
        }
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值