hdu 1690 Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4252    Accepted Submission(s): 1073


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 


题意 :有个公交系统是按公里区间来收费的。  超出区间就不能上车, 或者理解成不能到达。 

          有n个城市,  分别有自己的坐标, 一维坐标。 最后有个询问, 如果两个城市能互通, 那么就输出最少的话费, 否则输出不。

 

思路 : 因为城市的坐标差为20亿, 金额为10亿,  数字比较大。 所以用floyd() 要用 负数表示 无限大。

 

#include <stdio.h>
#include <stdlib.h>
#define max_size 105
int main() {
    int T, count = 1;
    scanf("%d", &T);
    while(T--) {
        int l[4];
        __int64 c[4];
        for(int i = 0; i < 4; ++i)
            scanf("%d", &l[i]);
        for(int i = 0; i < 4; ++i)
            scanf("%I64d", &c[i]);
        int n, m;
        scanf("%d%d", &n, &m);
        int num[max_size];
        for(int i = 0; i < n; ++i)
            scanf("%d", &num[i]);
        __int64 dis[max_size][max_size];
        for(int i = 0; i < n; ++i)
            for(int j = 0; j < n; ++j) {
                int temp = abs(num[i] - num[j]);
                if(temp > l[3])
                    dis[i][j] = -1;
                else if(temp > l[2])
                    dis[i][j] = c[3];
                else if(temp > l[1])
                    dis[i][j] = c[2];
                else if(temp > l[0])
                    dis[i][j] = c[1];
                else if(temp > 0)
                    dis[i][j] = c[0];
                else
                    dis[i][j] = 0;
            }
        for(int k = 0; k < n; ++k)
            for(int i = 0; i < n; ++i)
                if(dis[i][k] >= 0)
                    for(int j = 0; j < n; ++j)
                        if(dis[k][j] >= 0) {
                            __int64 temp = dis[i][k] + dis[k][j];
                            if(temp < dis[i][j] || dis[i][j] < 0)
                                dis[i][j] = temp;
                        }
        printf("Case %d:\n", count++);
        for(int i = 0; i < m; ++i) {
            int a, b;
            scanf("%d%d", &a, &b);
            if(dis[a-1][b-1] >= 0)
                printf("The minimum cost between station %d and station %d is %I64d.\n", a, b, dis[a-1][b-1]);
            else
                printf("Station %d and station %d are not attainable.\n", a, b); 
        }
    }
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值