【HDU4632】【Palindrome subsequence】

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 2641    Accepted Submission(s): 1065


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
  
  
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
  
  
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

Source
 

Recommend
zhuyuanchen520

对于所有情况只有2种可能, s[i] ....... s[j] 的形式 和非s[i] ...... s[j]的形式。

如果是s[i]....s[j]的形式,那么要求s[i] == s[j]  , 那么很容易知道dp[i][j] = dp[i+1][j-1] + 1. 其中1 是代表 s[i]s[j]

如果不是s[i]....s[j] 的形式,那么就是dp[i+1][j] + dp[i][j-1]  但是此时存在dp[i+1][j-1]的冗余减去就好了。


#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

int T;
char s[1010];
int dp[1010][1010];
const int MOD = 10007;
int main()
{
	int C = 1;
    scanf("%d",&T);
	while(T --)
	{
		memset(dp,0,sizeof(dp));
		memset(s,0,sizeof(s));
		scanf("%s",s);
		int len =strlen(s);
		for(int i=1;i<=len;i++)
		{
			dp[i][i]  = 1;
		}
		for(int j=2;j<=len;j++)
		{
			for(int i=j-1;i>=1;i--)
			{
				dp[i][j] = (dp[i][j] + dp[i+1][j] + dp[i][j-1] - dp[i+1][j-1] + MOD) % MOD;
				if(s[i-1] == s[j-1])
				{
					dp[i][j] = (dp[i][j] + dp[i+1][j-1] + 1) % MOD;
				}

			}
		}
		printf("Case %d: %d\n",C++,dp[1][len]);
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值