翻译布尔表达式

翻译布尔表达式
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
大家都学过了布尔表达式的翻译,其中有一个拉链-回填技术,这次我们就练习这个技术。

Input
多组输入,首先输入一个整数T,代表数据组数。

接下来每组输入为一行字符串,例如: a < b or c < d and e < f

每个符号都用空格间隔。

Output
假链跳到0,真链跳到1,表达式序号从100开始排。

Sample Input
1
a < b or c < d and e < f
Sample Output
100(j<,a,b,1)
101(j,,,102)
102(j<,c,d,104)
103(j,,,0)
104(j<,e,f,100)
105(j,,,103)
Hint
Source

/*****************
此程序专门处理逻辑表达式,将其转换成四元式输出
*****************/
#include <bits/stdc++.h>
using namespace std;
vector<string>tt;
string s,x;
int main()
{
    getline(cin,s);
    s+=" end";
    int true1 = 1,false1 = 100,id = 100;
    stringstream ss(s);
    while(ss>>x)
     {
        if(x == "or"||x == "end")
        {
            if(x == "or")false1+=2;
            else false1 = 0;
            int len = tt.size();
            for(int  i = 0; i < len - 3; i=i+3)
            {
                printf("%d(j%s,%s,%s,%d)\n",id,tt[i+1].c_str(),tt[i].c_str(),tt[i+2].c_str(),id+2);
                id++;///每生成一条四元式id加1
                printf("%d(j,_,_,%d)\n",id,false1);
                false1 = id++;
            }
            printf("%d(j%s,%s,%s,%d)\n",id,tt[len-2].c_str(),tt[len-3].c_str(),tt[len-1].c_str(),true1);
           true1 = id++;
           printf("%d(j,_,_,%d)\n",id,false1);
           id++;
           tt.clear();
           if(x == "end")break;
        }
        else if(x == "and")false1+=2;
        else tt.push_back(x);
    }
return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值