归并

Submit Statistic Discuss

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>
#include  <string.h>
struct st
{
    int data;
    struct st*next;
};
struct st*cr1(int c)
{
    int i;
    struct st *head,*t,*p;
    head=(struct st*)malloc(sizeof(struct st));
    head->next=NULL;
    t=head;
    for(i=1;i<=c;i++)
    {
        p=(struct st*)malloc(sizeof(struct st));
        scanf("%d",&p->data);
        p->next=NULL;
        t->next=p;
        t=p;
    }
    return head;
    }
struct st*he(struct st *h1,struct st*h2)
{

    struct st *head,*t,*p1,*p2;
     head=(struct st*)malloc(sizeof(struct st));
    head->next=NULL;
    t=head;
    p1=h1->next;p2=h2->next;
    while(p1&&p2)
    {if(p1->data<p2->data)
        {                         //加上p1->next=NULL;错,不能让他为空
       t->next=p1;
       t=p1;p1=p1->next;}
       else {                     //p2->next=NULL;同上。
       t->next=p2;
       t=p2;p2=p2->next;}}
      if(p1)
        t->next=p1;
      else t->next=p2;
       return head;
}
void pr(struct st *h)
{
    struct st*p;
    p=h->next;
    int n=0;
    while(p)
    {
        n++;
        if(n==1)
        printf("%d",p->data);
        else printf("% d",p->data);
        p=p->next;
    }
    printf("\n");
}

int main()
{
   int m,n;
   struct st *h1,*h2,*h;
   scanf("%d%d",&m,&n);
   h1=cr1(m);
   h2=cr1(n);
   h=he(h1,h2);
   pr(h);
    return 0;
}

这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值