数据结构实验之链表二:逆序建立链表
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
Input
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
Output
依次输出单链表所存放的数据。
Sample Input
10
11 3 5 27 9 12 43 16 84 22
Sample Output
22 84 16 43 12 9 27 5 3 11
Hint
不能使用数组!
Source
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
typedef struct st
{
int date;
struct st *next;
}linklist;
linklist* creat(int n)
{
linklist* head,*p;
head=(linklist*)malloc(sizeof(linklist));
head->next=NULL;
int i;
for(i=0;i<n;i++)
{
p=(linklist*)malloc(sizeof(linklist));
scanf("%d",&p->date);
p->next=head->next;
head->next=p;
}
return head;
}
void pre(linklist*L)
{
linklist*p=L->next;
int n=0;
while(p)
{
n++;
if(n==1)
printf("%d",p->date);
else
printf(" %d",p->date);
p=p->next;
}
}
int main()
{
linklist *L;
int n;
cin>>n;
L=creat(n);
pre(L);
return 0;
}