前序加中序建树

附,库函数

数据结构实验之求二叉树后序遍历和层次遍历
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description
已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input
输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output
每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Sample Input
2
abdegcf
dbgeafc
xnliu
lnixu
Sample Output
dgebfca
abcdefg
linux
xnuli

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <queue>
using namespace std;
typedef struct st
{
    char data;
    struct st *r,*l;
}tree;
char a[50],b[50];
tree*create(char a[],char b[],char n)
{
    tree *t;
    if(n==0)
        return NULL;
    t=(tree*)malloc(sizeof(tree));
    t->data=a[0];            //先建树根.
    int p;
    for(p=0;p<n;p++)  //在中序串中找与当前前序串中第一个对应的数据
    {
        if(b[p]== a[0])
            break;
    }
    /**********************
    说明做左子树中有p个元素,
    而且a[1]-a[4]与b[0]-b[3]所含元素相同,下一步就从a[1]-a[4]逐元素建树
    ***********************/
    t->l=create(a+1,b,p);
    t->r=create(a+p+1,b+p+1,n-p-1);//右子树中有n-1-p个元素
    return t;
}
void hou(tree*t)
{
    if(t)
    {
        hou(t->l);
        hou(t->r);
        cout<<t->data;
    }
}
/*************
层次遍历
************/
void cengci(tree*t)
{
    queue<tree*>q;
    q.push(t);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t)                                                 //若删除if提交会超时
        {
            cout<<t->data;
            q.push(t->l);
            q.push(t->r);
        }
    }
}
int main()
{
int t;
cin>>t;
while(t--)
{
    cin>>a>>b;
    int n=strlen(a);
    tree*t;
    t=create(a,b,n);
    hou(t);
    cout<<endl;
    cengci(t);
    cout<<endl;
}
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值