POJ Catch That Pig( - _ - )

POJ
Language:Default
Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 136418 Accepted: 42176

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

/************************************
think one:下一个节点如何去访问?
每个结点的下一步都有三条路:
+1,-1,*2
think two:怎样保证是最短路径?
3个if并行走三条路,
依次进队后逐个判断是否到达终点
发现到达终点的路径,break,
保证路径最短。
think 3:本题涉及"位置"和"步数"的同步,
采用结构体实现比较合适。
************************************/
#include <iostream>
#include<stdio.h>
#include <stdlib.h>
#include <queue>
#include <string.h>
using namespace std;
struct node
{
    int position,step;
};
queue <node> q;
int visited[200001],k;///数组开小会提示Runtime Error.
void BFS()
{
   int position,step;
   while(!q.empty())
   {
       node now=q.front();
       q.pop() ;   ///若不加出队,则下面赋值时永远是第一个结构体的值
       position=now.position;
       step=now.step;
       if(position == k)
       {
           cout<<step<<endl;
           break;
       }
       /***************************
       寻找下一个结点的位置同时更新步数。
       ****************************/
       if(position>=1&&!visited[position-1])
       {
           node next;    ///该结构体只在这一个if中有效
           visited[position-1]=1;
           next.position=position-1;
           next.step=step+1;
           q.push(next);
       }
       if(position<k&&!visited[position+1])
       {
           node next; ///还需定义
           visited[position+1]=1;
           next.position=position+1;
           next.step=step+1;
           q.push(next);
       }
       if(position<k&&!visited[2*position])
       {
           node next;
           visited[2*position]=1;
           next.position=2*position;
           next.step=step+1;
           q.push(next);
       }
   }
}
int main()
{
int n;
while(cin>>n>>k)
{
    if(!q.empty())
        q.pop();
    memset(visited,0,sizeof(visited));
    visited[n]=1;
    node t;
    t.position=n;
    t.step=0;
    q.push(t);  ///出发位置及当前走的步数进队。
    BFS();
}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值