连续子序列的长度的最小值(尺取法)

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3


给定长度为n的数列整数a0,a1,a2,a3 ..... an-1
以及整数S。求出综合不小于S的连续子序列的长度的
最小值。如果解不存在,则输出0。
ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 100100
#define min(a,b) a>b?b:a
#define max(a,b) a>b?a:b
#define INF 0xfffffff
int a[MAXN];
int v[MAXN];
int num;
int n,m,sum;
int main()
{
	int t,i,r,l;
	scanf("%d",&t);
	while(t--)
	{
		num=INF;
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		r=0;
		l=0;
		sum=0;
		for(;;)
		{
			while(r<n&&sum<m)
			{
				sum+=a[r];
				r++;
			}
			if(sum<m)
			break;
			num=min(num,r-l);
			sum-=a[l];
			l++;
		}
		if(num==INF)
		printf("0\n");
		else
		printf("%d\n",num);
	}
	return 0;
} 
转载:https://blog.csdn.net/helloiamclh/article/details/47685927

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值