USACO Section 2.2 Party Lamps

To brighten up the gala dinner of the IOI'98 we have a set of N (10 <= N <= 100) colored lamps numbered from 1 to N.

The lamps are connected to four buttons:

  • Button 1: When this button is pressed, all the lamps change their state: those that are ON are turned OFF and those that are OFF are turned ON.
  • Button 2: Changes the state of all the odd numbered lamps.
  • Button 3: Changes the state of all the even numbered lamps.
  • Button 4: Changes the state of the lamps whose number is of the form 3xK+1 (with K>=0), i.e., 1,4,7,...

A counter C records the total number of button presses.

When the party starts, all the lamps are ON and the counter C is set to zero.

You are given the value of counter C (0 <= C <= 10000) and the final state of some of the lamps after some operations have been executed. Write a program to determine all the possible final configurations of the N lamps that are consistent with the given information, without repetitions.

PROGRAM NAME: lamps

INPUT FORMAT

No lamp will be listed twice in the input.

Line 1:N
Line 2:Final value of C
Line 3:Some lamp numbers ON in the final configuration, separated by one space and terminated by the integer -1.
Line 4:Some lamp numbers OFF in the final configuration, separated by one space and terminated by the integer -1.

SAMPLE INPUT (file lamps.in)

10
1
-1
7 -1

In this case, there are 10 lamps and only one button has been pressed. Lamp 7 is OFF in the final configuration.

OUTPUT FORMAT

Lines with all the possible final configurations (without repetitions) of all the lamps. Each line has N characters, where the first character represents the state of lamp 1 and the last character represents the state of lamp N. A 0 (zero) stands for a lamp that is OFF, and a 1 (one) stands for a lamp that is ON. The lines must be ordered from least to largest (as binary numbers).

If there are no possible configurations, output a single line with the single word `IMPOSSIBLE'

SAMPLE OUTPUT (file lamps.out)

0000000000
0101010101
0110110110
In this case, there are three possible final configurations:
  • All lamps are OFF
  • Lamps 1, 4, 7, 10 are OFF and lamps 2, 3, 5, 6, 8, 9 are ON.

  • Lamps 1, 3, 5, 7, 9 are OFF and lamps 2, 4, 6, 8, 10 are ON.

#include <bits/stdc++.h>

using namespace std;

bool a[105];
int b[4];
int c, n;
int openlist[105], closelist[105], n1, n2, cnt;
string ans[20];

void reset (int n) {
  for (int i = 0; i <= n; i++) a[i] = 1;
}

bool ck() {
  int t = 0;
  for (int i = 0; i < 4; i++) {
    t += b[i];
  }
  if ((c & 1) == (t & 1) && c >= t) return 1;
  return 0;
}

void produce() {
  reset (n);
  if (b[0])
    for (int i = 0; i < n; i ++) a[i] ^= 1;
  if (b[1])
    for (int i = 1; i < n; i += 2) a[i] ^= 1;
  if (b[2])
    for (int i = 0; i < n; i += 2) a[i] ^= 1;
  if (b[3])
    for (int i = 0; i < n; i += 3) a[i] ^= 1;
}

bool ok() {
  for (int i = 0; i < n1; i++)
    if (!a[openlist[i]]) return 0;
  for (int i = 0; i < n2; i++)
    if (a[closelist[i]]) return 0;
  return 1;
}

int main() {
  freopen("lamps.in", "r", stdin);
  freopen("lamps.out", "w", stdout);
  scanf ("%d %d", &n, &c);
  while (1) {
    int x;
    scanf ("%d", &x);
    if (x == -1) break;
    openlist[n1++] = x - 1;
  }
  while (1) {
    int x;
    scanf ("%d", &x);
    if (x == -1) break;
    closelist[n2++] = x - 1;
  }
  for (b[0] = 0; b[0] < 2; b[0] ++)
    for (b[1] = 0; b[1] < 2; b[1] ++)
      for (b[2] = 0; b[2] < 2; b[2] ++)
        for (b[3] = 0; b[3] < 2; b[3] ++) {
          if (!ck()) continue;
          produce();
          if (ok()) {
            for (int i = 0; i < n; i++) ans[cnt].push_back(a[i] + 48);
            cnt++;
          }
        }
  if (!cnt) puts("IMPOSSIBLE");
  sort(ans, ans + cnt);
  for (int i = 0; i < cnt; i++) {
    puts(ans[i].c_str());
  }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值