PAT日志 1102

顽强的小白

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

在这里插入图片描述

Sample Output:

3 7 2 6 4 0 5 1 6 5 7 4 3 2 0 1

题目解析

这道二叉树的题比前面两道复杂一点点,主要是融合了中序遍历,层序遍历和后序遍历。给定二叉树,输出,左右翻转过的层序遍历和中序遍历
给出二叉树的所有节点,我没有用指针,用和不用,没有什么区别

  • 输入所有节点后,先要找到根节点:
    设置一个判断是否为根的数组,根节点的特征是不是任何一个结点的孩子,所以,在输入的时候可以排除所有为左右孩子的结点,最后遍历一下就能找出根节点了。
  • 剩下的难点是翻转二叉树,因为需要反转所有的分支,因此用后序遍历最好,这样就可以从树的末梢开始向主干进行翻转。

代码实现

#include <cstdio> 
#include <algorithm> 
#include <queue> 
using namespace std; int n;

struct {
 int data;
 int l;
 int r;
}node[10];
void reverse(int root){
 if(root==-1) return;
 reverse(node[root].l);
 reverse(node[root].r);
 swap(node[root].l,node[root].r);
}
void BFS(int root){
 queue<int> q;
 q.push(root);
 int cnt=0;
 while(!q.empty()){
  int now=q.front();
  printf("%d",now);
  cnt++;
  if(cnt<n) printf(" ");
  q.pop();
  if(node[now].l!=-1){
   q.push(node[now].l);
  }
  if(node[now].r!=-1){
   q.push(node[now].r );
  }
 }
}
int cnt=0;
void inOrder(int root){
 if(root==-1) return;
 inOrder(node[root].l);
 printf("%d",node[root].data);
 cnt++;
 if(cnt<n) printf(" ");
 
 inOrder(node[root].r);
}
int main(){
 scanf("%d",&n);
 char l,r;
 int isRoot[10];
 fill(isRoot,isRoot+n,1);
 getchar();
 for(int i=0;i<n;++i){
  node[i].data=i;
  scanf("%c %c",&l,&r);
  getchar();
  if(l<='9'&&l>='0'){
   node[i].l=l-'0';
   isRoot[l-'0']=0;
  }else{
   node[i].l=-1;
  }
  if(r=='-'){
   node[i].r=-1;
  }else{
   node[i].r=r-'0';
   isRoot[r-'0']=0;
  }
 }
 int root;
 for(int i=0;i<n;++i){
  if(isRoot[i]==1){
   root=i;
   break;
  }
 }
 reverse(root);
 BFS(root);
 printf("\n");
 inOrder(root);
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值