HDU1010Tempter of the Bone DFS、剪枝

6 篇文章 0 订阅

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 166686 Accepted Submission(s): 44241

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input
4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0

Sample Output
NO
YES

问题连接

问题描述

有一只小狗在迷宫里触碰到机关,迷宫的出口是关的,只有在第t秒(从小狗拾起骨头开始计算)门才打开。它所在的砖块会塌陷,每一秒它可以向上下左右的一个相邻的砖块跑,然后它刚刚所在的砖块会塌陷,问它是否能逃出迷宫。

问题分析

由于有门只有在第t秒的时候才开和上一秒所在位置的砖块会塌陷的特点,使得狗必须恰好在第t秒的时候到达出口,BFS是找到最短路径的,所以这题不能用BFS。
那就用DFS。但是如果是直接搜索,而不进行剪枝,那么会出现超时的问题,因为会将很多不可能逃出迷宫的情况一直进行下去。而剪枝可以更早地把一些不可能进行的情况终止掉,从而省去不必要的搜索时间。
这里有两个剪枝的地方:
1、如果从起点到终点的曼哈顿距离与开门的时间数值上奇偶不同,那么必不能在第t秒到达终点。因为在搜索的过程中,始终有所在点到终点的曼哈顿距离与剩余开门的时间的数值奇偶不同,那么必有剩余时间为0的时候,到门口的距离不为0。
2、如果从当前点到终点的曼哈顿距离数值比剩余开门的时间数值小,那么也不能成功逃出。
参考

代码如下

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int N=10;

bool flag;
int n,m,t;
int xd,xs,yd,ys;
int dirt[4][2]={{0,1},{1,0},{0,-1},{-1,0}};

char chart[N][N];
bool vis[N][N]; 

int md(int x1,int y1,int x2,int y2){//曼哈顿距离 
	return abs(x1-x2)+abs(y1-y2); 
}

bool judge(int x,int y,int time){
	/*
	这一点合理的条件:不超过边界、不是回头路、不撞墙、曼哈顿距离不比剩余开门时间大、
	在开门前不到'S'点 
	*/ 
	if(flag||x<0||x>=n||y<0||y>=m||vis[x][y]||chart[x][y]=='X'||md(x,y,xs,ys)>t-time) return 0;
	if(time!=t&&chart[x][y]=='S') return 0;
	if(time==t&&chart[x][y]=='S') flag=1;
	return 1;
}

void dfs(int x,int y,int time){
	int xt,yt;
	for(int i=0;i<4;i++){
		xt=x+dirt[i][0];
		yt=y+dirt[i][1];
		if(judge(xt,yt,time+1)){
			vis[xt][yt]=1;
			dfs(xt,yt,time+1);
			vis[xt][yt]=0;
		}
	}
}

int main(){
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	while(cin>>n>>m>>t){
		if(!n&&!m&&!t) break;
		
		for(int i=0;i<n;i++) cin>>chart[i];
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		{
			if(chart[i][j]=='S'){
				xs=i;
				ys=j;
			}
			else if(chart[i][j]=='D'){
				xd=i;
				yd=j;
			}
		}
		int d=md(xd,yd,xs,ys);
		if(d>t||(d+t)%2) {
		//起点到终点的曼哈顿距离如果比开门的时间的数值大,那么一定到不了
		//如果曼哈顿距离和开门时间数值奇偶不同,那么也不可能到 
			cout<<"NO"<<endl;
			continue;
		}
		memset(vis,0,sizeof(vis));
		flag=0;
		vis[xd][yd]=1;
		dfs(xd,yd,0);
		if(flag) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值