HDU1078 - FatMouse and Cheese - 记忆化搜索+dfs

1.题目描述:

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9442    Accepted Submission(s): 3991


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1080  1074  1158  1227  1059 
2.题意概述:

老鼠每次只能走k步停下来,停下的这个位置只能比上一个停留的位置大,并获取其价值,每次只能水平或垂直走,问最大能得到的价值

3.解题思路:

如果暴力枚举,n方级别虽然没有明确范围,但是肯定会t,最好就是结合动态规划来适当剪枝

4.AC代码:

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 100100
#define N 111
#define eps 1e-6
#define pi acos(-1.0)
#define e 2.718281828459
#define mod (int)1e9 + 7
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
int dp[N][N], mp[N][N];
int dir[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};
int n, k;
bool check(int x, int y)
{
  if (x < 0 || y < 0 || x >= n || y >= n)
    return false;
  return true;
}
int dfs(int x, int y)
{
  if (dp[x][y])
    return dp[x][y];
  int ans = 0;
  for (int i = 0; i < 4; i++)
    for (int j = 1; j <= k; j++)
    {
      int dx = x + dir[i][0] * j;
      int dy = y + dir[i][1] * j;
      if (check(dx, dy) && mp[dx][dy] > mp[x][y])
        ans = max(ans, dfs(dx, dy));
    }
  return dp[x][y] = ans + mp[x][y];
}
int main()
{
#ifndef ONLINE_JUDGE
  freopen("in.txt", "r", stdin);
  freopen("out.txt", "w", stdout);
  long _begin_time = clock();
#endif
  while (scanf("%d%d", &n, &k) != EOF && n != -1 && k != -1)
  {
    for (int i = 0; i < n; i++)
      for (int j = 0; j < n; j++)
        scanf("%d", &mp[i][j]);
    memset(dp, 0, sizeof(dp));
    printf("%d\n", dfs(0, 0));
  }

#ifndef ONLINE_JUDGE
  long _end_time = clock();
  printf("time = %ld ms.", _end_time - _begin_time);
#endif
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值