hdu-1078-FatMouse and Cheese(dfs+记忆化)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1078

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

 

 

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.

 

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

 

 

Sample Input

 

3 1 1 2 5 10 11 6 12 12 7 -1 -1

 

 

Sample Output

 

37

题目大意:这个题目好绕啊,读了半天没读懂,还是在队友(猛哥)的帮助下才读懂了题,类似之前的滑雪(poj-1088)

给出一个地图,上面的数字代表那个地方的事物的数量,小老鼠从0,0点出发(只能从0,0点出发!),问小老鼠最多能吃多少个食物。

小老鼠一次只能走k步以内,只能水平或垂直行走,只能去有更多的食物的地方(要去的地方要比目前的地方的食物更多)

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 998244353
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);

int dp[110][110];
int map[110][110];
int fx[4]={1,-1,0,0},fy[4]={0,0,1,-1};
int n,k;

int dfs(int x,int y)
{
	if(dp[x][y])
		return dp[x][y];
	int res=map[x][y];
	for(int i=0;i<4;++i)
	{
		for(int j=1;j<=k;++j)
		{
			int nx=x+fx[i]*j,ny=y+fy[i]*j;
			if(nx>=0&&nx<n&&ny>=0&&ny<n)
			{
				if(map[nx][ny]>map[x][y])
					res=max(res,dfs(nx,ny)+map[x][y]);
			}
		}
	}
	return dp[x][y]=res;
}

int main()
{
	std::ios::sync_with_stdio(false);
	while(cin>>n>>k)
	{
		if(n==-1&&k==-1)
			break;
		clean(dp,0);
		for(int i=0;i<n;++i)
		{
			for(int j=0;j<n;++j)
				cin>>map[i][j];
		}
//		int ans=0;
//		for(int i=0;i<n;++i)//小老鼠只能从(0,0)走没看见WA了两次。。
//		{
//			for(int j=0;j<n;++j)
//			{
//				ans=max(ans,dfs(i,j));
//			}
//		}
//		for(int i=0;i<n;++i)
//		{
//			for(int j=0;j<n;++j)
//				cout<<dp[i][j]<<" ";
//			cout<<endl;
//		}
		cout<<dfs(0,0)<<endl;
		
	}
	
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值