HDU1385 - Minimum Transport Cost - 最短路+字典树路径

1.题目描述:

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10691    Accepted Submission(s): 2954


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1142  2066  1690  2722  1596 
2.题意概述:

给你一个无向图,求任意两点的最短路。附加条件2个:
01 - 经过每个节点必须缴纳一点的税。
02 - 如果有多条最短路径,寻找字典序最小的路径。

3.解题思路:

最开始一直在拍dijikstra,发现一个问题,要求是字典序最小路径,那么不能简单地记录前驱节点,因为我们关心的是路径字典序最小,关心的是起点的后继。那么打印路径的时候就直接从前向后打印

转Floyd,卒

dijkstra有博主配合dfs实现了,贴个连接,有时间再啃:HDU1385的三种方法实现

4.AC代码:

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 111
#define eps 1e-6
#define pi acos(-1.0)
#define e 2.718281828459
#define mod (int)1e9 + 7
using namespace std;
typedef long long ll;
int mp[maxn][maxn], dis[maxn][maxn], pre[maxn][maxn], cost[maxn];
void floyd(int n)
{
  for (int i = 1; i <= n; i++)
  {
    for (int j = 1; j <= n; j++)
    {
      dis[i][j] = mp[i][j];
      pre[i][j] = j;
    }
  }
  for (int k = 1; k <= n; k++)
  {
    for (int i = 1; i <= n; i++)
    {
      for (int j = 1; j <= n; j++)
      {
        if (dis[i][j] > dis[i][k] + dis[k][j] + cost[k])
        {
          dis[i][j] = dis[i][k] + dis[k][j] + cost[k];
          pre[i][j] = pre[i][k];
        }
        else if (dis[i][j] == dis[i][k] + dis[k][j] + cost[k])
        {
          if (pre[i][j] > pre[i][k] && i != k)
            pre[i][j] = pre[i][k];
        }
      }
    }
  }
}
void print(int i, int j)
{
  printf("From %d to %d :\n", i, j);
  printf("Path: ");
  int k = i;
  printf("%d", i);
  while (k != j)
  {
    printf("-->%d", pre[k][j]);
    k = pre[k][j];
  }
  puts("");
  printf("Total cost : %d\n\n", dis[i][j]);
}
int main()
{
#ifndef ONLINE_JUDGE
  freopen("in.txt", "r", stdin);
  freopen("out.txt", "w", stdout);
  long _begin_time = clock();
#endif
  int n;
  while (~scanf("%d", &n), n)
  {
    /*init*/
    for (int i = 1; i <= n; i++)
    {
      for (int j = 1; j <= n; j++)
        mp[i][j] = INF;
      mp[i][i] = 0;
    }
    /*read*/
    for (int i = 1; i <= n; i++)
      for (int j = 1; j <= n; j++)
      {
        int tmp;
        scanf("%d", &tmp);
        if (tmp != -1)
          mp[i][j] = tmp;
      }
    for (int i = 1; i <= n; i++)
      scanf("%d", &cost[i]);
    floyd(n);
    /*print*/
    int sta, ed;
    while (~scanf("%d%d", &sta, &ed), sta != -1, ed != -1)
      print(sta, ed);
  }
#ifndef ONLINE_JUDGE
  long _end_time = clock();
  printf("time = %ld ms.", _end_time - _begin_time);
#endif
  return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值