Minimum Transport Cost(ZOJ - 1456)

题目:

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and
a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.
You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.
The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N
a21 a22 … a2N

aN1 aN2 … aNN
b1 b2 … bN

c d
e f

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :
Path: c–>c1–>…–>ck–>d
Total cost : …

From e to f :
Path: e–>e1–>…–>ek–>f
Total cost : …

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

思路:这是最短路径的问题,不过要求出所走的路径是什么?
我用的是Floyd算法,因为除了所走的初末位置其他点都需要税款,所以此时的最短经费就是所要的运费和税款。然后就是路径了,首先用二维数组b[][]去存储一点到另一个点的路径,也就是当当前的e[i][j]需要更新时,从一点去另一个点也需要重新规划路径。
注意:如果有更多的最小路径,则输出点最小的路径,也就是当e[i][j]不需要更新时,该点与另一个点取较小的。

程序代码:

#include<stdio.h>
int e[2000][2000],n,a[5000],b[2000][2000];
int inf=999999999;
void floyd()
{
	int k,i,j,ma;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			b[i][j]=j;	
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(e[i][k]<inf&&e[k][j]<inf)
				{
					ma=e[i][k]+e[k][j]+a[k];
					if(e[i][j]>ma)
					{
						e[i][j]=ma;
						b[i][j]=b[i][k];
					}
					else if(e[i][j]==ma)
					{
						if(b[i][j]>b[i][k])
							b[i][j]=b[i][k];
					}
				}
			}
/*	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			printf("*%d ",b[1][j]);
	printf("\n");*/
}
int main()
{
	int i,j,w,x,y,t1,t2;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				{
					scanf("%d",&w);
					if(w==-1)
						w=inf;
					e[i][j]=w;
				}
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		floyd();
		while(scanf("%d%d",&x,&y)!=EOF)
		{
			if(x==-1&&y==-1)
				break;
			t1=x;
			t2=y;
			printf("From %d to %d :\n",x,y);
			printf("Path: %d",x);
			while(x!=y)
			{
				printf("-->%d",b[x][y]);
				x=b[x][y];
			}
			printf("\n");
			printf("Total cost : %d\n",e[t1][t2]);
			printf("\n");
		}	
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值