HDU1595 - find the longest of the shortest - 最短路变形+暴力

1.题目描述:

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3281    Accepted Submission(s): 1209


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
 

Author
ailyanlu
 

Source
 

Recommend
8600
 
2.题意概述:

给你一个无向图,告诉你其中某条路被X了,没法走,问你在最坏情况下的最短路是多少?

3.解题思路:

很容易想到暴力去枚举被X的路,一个优化是,对最短路有影响的边肯定在最开始的最短路路径上(不然你X别的边也不会影响到最开始那条路径),那么先spfa一遍记录一下路径,再在路径上暴力去X,更新最大值即可。

ps:这题wa了很久,dijkstra写的不多,所以写残了很多遍。而且特别需要注意的堆优化的dijkstra重定义operator符号和比较次序。

4.AC代码:

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 100100
#define N 1111
#define inf 0x7f
#define eps 1e-6
#define pi acos(-1.0)
#define e exp(1.0)
using namespace std;
const int mod = 1e9 + 7;
typedef long long ll;
typedef unsigned long long ull;
int mp[N][N], dis[N], pa[N];
bool vis[N];
bool flag;
priority_queue<pair<int, int>, vector<pair<int, int>>, greater<pair<int, int>>> q;
void dijkstra(int sta, int n)
{
	memset(vis, 0, sizeof(vis));
	fill(dis, dis + n + 1, INF);
	dis[sta] = 0;
	q.push(make_pair(0, sta));
	while (!q.empty())
	{
		int u = q.top().second;
		q.pop();
		if (!vis[u])
		{
			vis[u] = 1;
			for (int i = 1; i <= n; i++)
			{
				int v = i;
				int w = mp[u][i];
				if (dis[v] > dis[u] + w)
				{
					dis[v] = dis[u] + w;
					if (flag)
						pa[v] = u;
					q.push(make_pair(dis[v], v));
				}
			}
		}
	}
}
int main()
{
#ifndef ONLINE_JUDGE
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
	long _begin_time = clock();
#endif
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				mp[i][j] = (i == j ? 0 : INF);
		flag = 1;
		memset(pa, 0, sizeof(pa));
		while (m--)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			mp[u][v] = mp[v][u] = min(mp[u][v], w);
		}
		dijkstra(1, n);
		flag = 0;
		int ans = dis[n];
		for (int i = n; i != 0; i = pa[i])
		{
			int tmp = mp[i][pa[i]];
			mp[i][pa[i]] = mp[pa[i]][i] = INF;
			dijkstra(1, n);
			ans = max(ans, dis[n]);
			mp[i][pa[i]] = mp[pa[i]][i] = tmp;
		}
		printf("%d\n", ans);
	}
#ifndef ONLINE_JUDGE
	long _end_time = clock();
	printf("time = %ld ms.", _end_time - _begin_time);
#endif
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值