HDU1595 find the longest of the shortest(dijk+路径记录+枚举)

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3333    Accepted Submission(s): 1243


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
 

大致思路很好想,先求一条最短路,记录下路径,然后枚举删去每一条边刷新最大值即可,主要在于不会计算时间复杂度不敢写,毕竟从起点到终点最多n-1条边而dijkstra又是O(N^2)的复杂度,这样算来都O(N^3)的复杂度了,N还是1000,搞不准时间

注意删边之后路径会改变,只记录未删时候的路径

1279MS

#include<stdio.h>  
#include<string.h>  
#include<math.h>  
#include<algorithm>  
#include<iostream>  
#include<queue>  
#define inf 0x3f3f3f3f  
#define mem(a,b) memset(a,b,sizeof(a))  
using namespace std;  
const int N=1005;  
typedef long long ll;  
int n,m,flag;  
int pre[N],dis[N];  
bool vis[N];  
int e[N][N];  
void dijkstra(int x)  
{  
    for(int i=1; i<=n; i++)  
    {  
        dis[i]=inf;  
        vis[i]=false;  
    }  
    int u;  
    dis[x]=0;  
    for(int i=1; i<n; i++)  
    {  
        int minn=inf;  
        for(int j=1; j<=n; j++)  
        {  
            if(!vis[j]&&minn>dis[j])  
            {  
                minn=dis[j];  
                u=j;  
            }  
        }  
        vis[u]=1;  
        for(int k=1; k<=n; k++)  
        {  
            if(dis[k]>dis[u]+e[u][k])  
            {  
                dis[k]=dis[u]+e[u][k];  
                if(!flag)  
                {  
                    pre[k]=u;  
                }  
            }  
        }  
    }  
}  
  
int main()  
{  
    while(~scanf("%d%d",&n,&m))  
    {  
        mem(pre,-1);  
        for(int i=1; i<=n; i++)  
        {  
            for(int j=1; j<=n; j++)  
            {  
                if(i==j)e[i][j]=0;  
                else e[i][j]=inf;  
            }  
        }  
        int u,v,w;  
        for(int i=0; i<m; i++)  
        {  
            scanf("%d%d%d",&u,&v,&w);  
            if(w<e[u][v])  
                e[u][v]=e[v][u]=w;  
        }  
        flag=0;  
        dijkstra(1);  
        flag=1;  
        int temp,maxx=dis[n];  
        for(int i=n;~i; i=pre[i])  
        {  
            if(pre[i]==-1)break;
            temp=e[pre[i]][i];  
            e[pre[i]][i]=inf;  
            dijkstra(1);  
            maxx=max(maxx,dis[n]);  
            e[pre[i]][i]=temp;  
        }  
        printf("%d\n",maxx);  
  
    }  
}  







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值