杭电1595 find the longest of the shortest

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2511    Accepted Submission(s): 883


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
 

Author
ailyanlu
 


调试了整整两个小时,求最短路径,断开一条路之后的最短路径里边的最大值,由于断开路径较多,但是有很大一部分断开之后不影响,排除不影响部分,在路全部畅通的情况下,记录此状态的路径,断开时只需要断开该路径上的一条路即可,理论上还是会超时的,因为路有1000 条,每次都调用迪杰斯特拉算法,则时间复杂度会达到1000^3,所以局部进行了优化,附代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 0x3f3f3f3f
using namespace std;
int map[1100][1100],dis[1100],vis[1100],i,j,k,l,m,n,x,y,z,p[1100];
void dj(int v)//迪杰斯特拉算法 
{
    int i,j,k;
    memset(vis,0,sizeof(vis));
   	memset(dis,N,sizeof(dis));
    dis[1]=0;//标记开始点已经被使用 
    for(i=1;i<=m;i++)
    {
        int Min=N;
        for(j=1;j<=m;j++)
        {
            if(!vis[j]&&dis[j]<Min)
            {
                Min=dis[j];
                k=j;
            }
        }
        if(Min==N)//优化,如果没有找到较小的,直接结束 
        return ;
        vis[k]=1;
        for(j=1;j<=m;j++)
        if(!vis[j]&&dis[k]+map[k][j]<dis[j])
        {
        	dis[j]=dis[k]+map[k][j];
        	if(v)
        	p[j]=k;//p数组记录路径 ,即j点的下一个点 
        }   
    }
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
    	memset(p,0,sizeof(p));
        memset(map,N,sizeof(map));
        for(i=1;i<=m;i++)
        map[i][i]=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(map[x][y]>z)
            map[x][y]=map[y][x]=z;
        }
        //int ans=dj(1);
        //printf("++%d\n",ans);
        dj(1);
        int Max=dis[m];
        for(i=m;i!=1;i=p[i])
        {
        	z=map[i][p[i]];//把当前点和路径上的当前点的下一个点断开 
            map[i][p[i]]=map[p[i]][i]=N;
            dj(0);
            Max=max(Max,dis[m]); 
            map[i][p[i]]=map[p[i]][i]=z;
        }
        printf("%d\n",Max);
    }
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值