G - MZL's simple problem

A simple problem 
Problem Description 
You have a multiple set,and now there are three kinds of operations: 
1 x : add number x to set 
2 : delete the minimum number (if the set is empty now,then ignore it) 
3 : query the maximum number (if the set is empty now,the answer is 0)
InputThe first line contains a number  NN ( N106N≤106),representing the number of operations. 
Next  NN line ,each line contains one or two numbers,describe one operation. 
The number in this set is not greater than  109109.OutputFor each operation 3,output a line representing the answer.Sample Input
6
1 2
1 3
3
1 3
1 4
3
Sample Output
3

4

这题TLE了很多次,一直不明白为什么,到后来才发现是因为输出用了cout,这题还要注意,因为这是集合,所以里面的元素是不能重复的



#include <cstdio>
#include <iostream>
#include <set>
using namespace std;
typedef long long ll;
const int inf = 1e6 +10;
set<int>s;
int main()
{
    int num;
    scanf("%d", &num);
    while(num --){
        int way;
        scanf("%d", &way);
        if(way == 1){
            int val;
            scanf("%d", &val);
            s.insert(val);
        }else if(way == 2){
            if(!s.empty()){
               s.erase(s.begin());
            }
        }else {
            if(!s.empty()){
                set<int>::iterator it = s.end();
                it --;
                printf("%d\n", *it);
            }else {
                printf("0\n");
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
void Cin(Books *abs){ int i = 0; int g; cout<<"添加几个课程?"<<endl; xiuf(&g); if(abs->number + g > 5){ cout<<"太多了,进不去了!!!"<<endl; system("pause"); system("cls"); }else{ for(i=0;i<g;i++){ abs->number++; cout<<"输入课程名字"<<endl; string mzl; cin>>mzl; abs->ClassArray[abs->number].name = mzl; cout<<"输入课程编号"<<endl; string numberl; cin>>numberl; abs->ClassArray[abs->number].number = numberl; cout<<"输入课程性质"<<endl; string forml; cin>>forml; abs->ClassArray[abs->number].form = forml; cout<<"输入课程学分"<<endl; int gradel; xiuf(&gradel); abs->ClassArray[abs->number].grade = gradel; cout<<"输入课程学时"<<endl; int timel; xiuf(&timel); abs->ClassArray[abs->number].time = timel; cout<<"输入课程授课学时"<<endl; int finishtimel; xiuf(&finishtimel); abs->ClassArray[abs->number].finishtime = finishtimel; cout<<"输入课程实验学时"<<endl; int experiencel; xiuf(&experiencel); abs->ClassArray[abs->number].experience = experiencel; cout<<"添加成功"<<endl; abs->ClassArray[abs->number].people = abs->number *10; system("pause"); system("cls"); ofstream out("kc.txt",ios::app);//app表示每次操作前均定位到文件末尾 if(out.fail()){ cout<<"error\n"; } out<<"课程名字:"<<mzl<<endl; out<<"课程编号:"<<numberl<<endl; out<<"课程性质:"<<forml<<endl; out<<"课程学分:"<<gradel<<endl; out<<"课程学时:"<<timel<<endl; out<<"课程授课学时:"<<finishtimel<<endl; out<<"课程实验学时:"<<experiencel<<endl; out.close(); }} }
06-13

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值