hdu 5349 MZL's simple problem

hdu 5349 的传送门

Problem Description

A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)

Input

The first line contains a number N (N≤106),representing the number of operations.
Next N line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than 109.

Output

For each operation 3,output a line representing the answer.

Sample Input

6
1 2
1 3
3
1 3
1 4
3

Sample Output

3
4

题目大意:给你一个数,表示有几行,然后给你一个a和x,如果a等于1的话,就向里面增加一个数,如果a等于2的话 ,就删除集合中最小的一个数,如果等于a==3 的话,就输出最大的数;
解题思路:STL,集合;

具体见代码:

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;
set<long long >::iterator it;
set<long long > s;

int main()
{
    long long n, a, x;
    scanf("%lld",&n);
    s.clear();
    while(n--)
    {
        scanf("%lld",&a);
        if(a == 1)
        {
            scanf("%lld",&x);
            s.insert(x);
        }
        else if(a == 2)
        {
            if(!s.empty())
               s.erase(s.begin());
        }
        else if(a == 3)
        {
            if(s.empty())
                puts("0");
            else
            {
                it=s.end();
                it--;
                printf("%lld\n",*it);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值